I just bought this Samsung Galaxy S, installed the Kies software, then it automatically downloaded an update for my phone. I plugged in my phone and it began the update.

After a few seconds the client said something like 'Error: DLL not found.' (I can't remember exactly what it said.) The update stopped. (In the client.) On the phone's screen, it said "Downloading...". It said this for around 2 hours before I eventually decided to take the battery out and attempt the update again. But, when I restarted the device, the following symbol was displayed on the screen:


I plugged the phone into my PC, and Kies and it said "update failed, Emergency recovery." The client couldn't connect and told me to refer the the manual on how to boot my phone into recovery mode. I tried it and nothing happened. The same symbol is still on the screen, all I can do with it is turn it on and off.

Is there any way I can use my phone again? I don't care if I have to do a factory restore and lose all its data.

2 Answers 2


The below assumes you have the GT-i9000 (international Galaxy S).

Go to this XDA thread and download the newest 2.2 firmware for your region. Download Odin for Windows (search for "Heimdall" if you are on Linux). Then do the following:

  1. Put your phone into Download mode
    1. Remove the battery
    2. Hold VolumeDown plus the Home key plus Power. While holding,
      1. Reinsert the battery.
      2. Release the Power button, still holding the others, about 1 second after the white "GT-I9000" text appears.
      3. After a few seconds a yellow triangle with an android in it should appear, this is Download Mode. If it doesn't, try this again while holding Power the whole time.
  2. Start up Odin.
  3. Attach the phone to your PC via USB so that Odin recognizes it.
  4. Load the .zip file you downloaded (the ROM/firmware) into the PDA field of Odin.
  5. Load the 512 .pit file into the PIT field of Odin.
  6. Check "Re-partition".
  7. Hit Start. Odin will tell you when it's done; if it fails, reboot your phone and try again. (This happens occasionally).

Note that you do this at your own risk; Odin is very powerful and misusing it can damage your phone. I've used it dozens of times myself safely.

  1. Connect to kies in this mode as shown in your photograph.
  2. Follow instructions for emergency firmware recovery.

It worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .