5

I have a Samsung Galaxy S4 LTE phone (GT-i9505) and I put CyanogenMod 11 (M12) on it. Previously I put CWM_6.0.4.7_Touch_GT-I9505.tar as Kernel to get root.

Now I want to use TitaniumBackup Pro and the feature to protect single backups, but this is not working. I noticed that a chmod or chown (as root) doesn't change anything:

Example:

su 
chmod 075 /storage/emulated/0/TitaniumBackup/somebackupfile.tar.gz
chown system /storage/emulated/0/TitaniumBackup/somebackupfile.tar.gz

It is still 660 with root:sdcard_r

If I cannot set these I cannot protect the backup. What am I doing wrong?

frank

EDIT 2015-01-29: I solved the problem with chmod 777 to /mnt/media_rw which I had to put into init.d as it reset again after reboot. So I did this in my init.d: busybox chmod 777 /mnt/media_rw after this I can find the media_rw folder in Titanium and chose it. Now it works.

  • 1
    possible duplicate of Why can I not assign exec permissions to a file on the SD card? – Chahk Nov 26 '14 at 15:39
  • This I thought first but on my previous S2 with CM 10.2.1 I had no worries at all with this Titanium Feature on my internal SD-Card. – franc Nov 26 '14 at 21:18
  • Is chmod 075 what you want – or does a typo cause the issue here, and you rather intended a chmod 0755? Though chmod also accepts 3-digit values, that doesn't always work out; and in this special case: it makes no sense the owner has no permissions while others have ;) Also: Could you please check what file-system is used there (e.g. issuing the mount command)? – Izzy Dec 1 '14 at 15:38
  • @izzy : 075 is indeed what I ment. It is like this on my S2, so I thought it must be this way. But now I made some symlink to the external sd-card so I can use the path /mnt/media_rw/sdcard1 and now it is working with the lock in TitaniumBackup, what I initially searched. The permission on the locked backups is now 551 and on the not locked backups it is 771. – franc Dec 1 '14 at 20:45
  • Similarly chgrp is not working in my case. Did yours work eventually? – Prahlad Yeri Oct 20 '16 at 8:04
2

the chmod and chown binaries you are using there are from the android toolbox and are pretty lightweight. You can use more powerful binaries from busybox. Maybe this solves your problem as I also encountered issues with the small set of features of the toolbox ultilities.

busybox chmod 075 /storage/emulated/0/TitaniumBackup/somebackupfile.tar.gz
busybox chown system /storage/emulated/0/TitaniumBackup/somebackupfile.tar.gz

EDIT: Sometimes it just helps reading carefully. Didn't get that your sdcard is an emulated sdcard which is implemented permissionless. This means it is right behavior that chmod/chown do not work at all here:

From: https://source.android.com/devices/storage/config.html

Devices may provide external storage by emulating a case-insensitive, permissionless filesystem backed by internal storage.
  • No, this not working. No change. – franc Nov 26 '14 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.