2

I have a Android Matricom G-Tab Quantum Tablet with 1 GB of internal memory (tablet and system Space) and a 16 GB internal storage.

I was running out of space in the 1 GB memory and since Android doesn't use the internal storage just for pics and videos I decided to partition it so I could move some apps with Link2SD.

I partitioned the 16 GB internal storage using MiniTool Partition wizard like this:

  • 8 GB FAT32 as primary partition
  • The rest as an ext4 partition

The partitioning was done correctly, but when my tablet tried to read the internal SD it didn't show 8 GBs as I expected. It only showed 363 MB. So I connected the SD card to my PC again, and I ran diskpart and "supposedly" cleaned all the partitions from the SD card, deleting any partitions in the process and restoring back its original size and everything and formatting it as FAT32.

The PC shows that the SD card has a FAT32 partition of 8 GB and it lists 8 GB as the whole space of the SD, card so it's missing the space from the ext4 partition. When I open the Minitool Partition wizard it only displays the 8 GB FAT32 partition as the "whole" space and only partition of the SD card. There are no signs of the ext4 partition (or its space).

I put the SD card on a Linux based system to look for the ext4 partition, but with no effort Gparted only shows the FAT32 partition just like Minitool Partition Wizard!

Also, now when I connect the tablet to the PC, it also reads a second disk of 1kb but you can't open it or format it! I'm suspecting this has something to do with the issue, but I don't know what do with it!

Now in the tablet it only displays the 363 MB as internal storage, but I can't seem to access it from anywhere. I don't know where this 354 partition came from. If I put files on the 8 GB partition I can't access them on the device, and If I boot to recovery (Stock Android recovery) and try to open a file from the "internal SD card" it says:

"Cant mount /sdcard"

If I insert an external SD card I can only access it from the recovery, but from the device always shows the 354 MB as the only storage.

I also noted if I open the storage folder with a rooted file explorer it reads these folders:

  • sdcard0
  • sdcard1
  • sdcard2
  • extsd
  • usbhost

I remember that before all of this happened the sdcard2 folder didn't exist.

I have tried these apps to "restore" my internal SD card back to its full size but none of them has worked:

  • SD Card Formatter
  • Mini Tool Partition Wizard
  • EaseUS Partition Master
  • HP Format Tool

It's important to know that now when I open Mini Tool Partition Master and the tablet is connected, it crashes. If I open it without the the tablet connected it starts fine. After it starts, if I connect the tablet to the PC and refresh the device list, it loads the 8 GB FAT32 disk and the 1kb with no partition disk. If I click the 1kb disk it crashes and closes abruptly!

I also tried a bit of testdisk but I don't understand it very well. Supposedly it restored my partition table but I cant see a difference.

If I connect the tablet as an media system I can access 354 MB storage!

I inserted a 2 GB external SD card and it reads the external SD card, so I partitioned the it (1 GB FAT and 1 GB ext2) and when I inserted it back it only read 354 MB just as the internal SD card! Also, if I connect the tablet with the external SD card to the PC, it only lists the 1 GB FAT partition and doesn't list its ext2 partition nor the internal SD card! I went back and deleted all the partitions from the external SD card and inserted it again, and now it displays its 2 GB size correctly!

Is there other way to access the internal SD card?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.