0

I recently had to factory reset my phone, a Samsung GT-S5302 with Android 2.3.6. Now I'm trying to reinstall apps from Google Play store, but one of them says "your device is not compatible with this version" on the play store page. This is nonsense, as it was working until yesterday, and it had been installed correctly and using the official way from play store months ago, on the same phone with the same Android version. Play store, seen from my PC, even still sees that app as installed, but at the same time says it's incompatible.

I contacted the user service of the app and they told me the app is compatible with android 2.3.3 onwards, therefore it's a Play problem. I also already tried to perform the steps suggested in the troubleshooting (resetting play's updates, download manager's cache and all that), with no results.

  • 1
    Try to download the apk from somewhere else (third-party stores, there are many). Then install it. If it's compatible, it will install without any issues. – GiantTree Jan 4 '15 at 19:54
  • I tried doing so, by simply moving the apk and tapping it. It opens with "app installer" or something similar, works for a few seconds and then happily says « √ App not installed.» – Bzazz Jan 5 '15 at 15:48
  • Then I might need to take a look at the log (adb logcat). There it will say what happens when you install the app and also where it fails. – GiantTree Jan 5 '15 at 15:58
  • How can I get it? I never used command line. Actually, there should be an "official" solution to this problem. If I can't find it, anyway, I can also go for unofficials. – Bzazz Jan 5 '15 at 16:16
  • There is no official or unofficial. The log will say where the installation fails. Easiest for you is to run the command pm install <.apk path>. Then it will give oyu a message about the success of the installation. – GiantTree Jan 5 '15 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.