1

I purchased an Asus Transformer Prime TF201 a couple years ago. I added a pattern lock on this tablet so our kids would not use it all the time. One of them decied to try the pattern too many times. Now, it is stuck at the Too Many Pattern Attempts screen. This has happened before and I was able to reset it by using my Google Account (wifi was on). However, this time, I had to charge the device first before turning it on and discovered that it was in lock mode again! I tried to get past the lock screen using Google credentials, but no go.

I am assuming the wifi turns off when the battery is drained. And because wifi is off, it cannot authenticate using my Google Account. I know my Google credentials and I also know the pattern, but I cannot use them! I have pics and videos of our children that I do not want to loose.

I have been doing research for a few days now and it seems that if USB debugging was enabled, I could just run some adb commands (using the adb executable) and reset it to the point where I could try the pattern again. But USB debugging is NOT enabled!

I am not sure this device is rooted?? I know that when I was using it, I was able to see all the directories (using the AndSMB app, but not sure if i was able to write to all dirs). It is a stock device with no mods. It was upgraded to 4.1.1 (it was an update supplied from Asus).

Some good news: I am able to start the device in fastboot mode and it is detectable using the fastboot command tool (via Windows or Linux) while connected to supplied usb cable.

There is a tool called Android Script Creator (by Octanium) that can create an update zip file from custom commands. I was able to create a zip file named Update.zip with the following commands..

ui_print("attempting to start wifi..");
run_program("svc", "wifi", "enable");
ui_print("done");

Questions

  1. Am I on the right track?
  2. Will the script I wrote work?
  3. How do I run this update file I created?
  4. Does the Update.zip file need to be flashed (or copied - what's the difference?) to an external SD card?
  5. Can I use the fastboot tool to place this zip file on the internal memory and have it run?

Additional Info.. i found some links that may help.. but not sure what to do..

This link points to an article that describes how to use an update zip file, but it says to flash the CWM. Is the CWM necessary to run an Update.zip file? http://www.morethantechnical.com/2013/01/29/a-creative-way-to-bypass-pattern-lock-on-android/

This page seems to have the recovery files (and it has Transformer Prime), but what do i do with the recovery file? It is an *.IMG file! https://www.clockworkmod.com/rommanager

  • Some things: an update.zip has to be flaashed via recovery or fastboot. A recovery is usually a .img or .tar(.md5) file. They are complete file system images of the recovery as its a normal partition that need to be overwritten. As for the script: Try it. It shouldn't harm your device from what I understand. – GiantTree Feb 1 '15 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.