2

The Macbook Pro does recognise my Galaxy S4. I've just downloaded and opened the latest version of Kies, restarted everything, and the "connecting" wheel just keeps going round and round and round. I need to transfer a large video file from the phone to the computer.

0

There are a few ways to mount an Android device to your Mac. I'm not sure if all the following are supported on the Galaxy S4, depending in part on what version of Android you have. (There are other methods for accessing files on your phone, some of which would require root.. but these listed below are built into most recent versions of Android.)

The file access methods include:

Picture Transfer Protocol (PTP) -- this is basically a mode where your phone pretends to be a digital camera and is accessed as such. Picture/media-related apps such as iPhoto recognize it as a camera and will ask to auto-import pictures (and possibly videos as well) from the DCIM folder. Depending on the format of your large video, this may be the way to go if you're importing directly into a media app.

USB Mass Storage (UMS) -- this method basically turns your phone into a USB flash drive. The computer recognizes and "mounts" it as it would a normal flash drive. Unfortunately, when you mount your phone's external storage to your computer, your phone itself can't access the content-- it can't be mounted in two places at once. But for quick drag-and-drop, this method works pretty well.

Media Transfer Protocol (MTP) -- this is a method of accessing the files on your phone which simultaneously doesn't block the phone's own apps from accessing the external directory. It works a little smarter by working at the file/directory level rather than just handing over the whole block device the way UMS does. MTP is what the aforementioned Android File transfer app is for-- it let's you to access the files and integrates with OS X. More info here.

To access these different types of connections on Android, generally you go to Settings, then to Storage. If your device is plugged into your Mac, you should see three dots in the upper right corner of the action bar at the top of the screen. The menu item says something like USB computer connection. From there, you can select from the above connection types.

Again, depending on your version of Android, the options may not all be there. But hopefully one of the three will be there and will work for ya.

  • My thanks to everyone for their suggestions. I gather the problem is that I do not have the original cable that came with the phone, so my Macbook Pro cannot recognise it. It recognises that something is there, but just keeps asking me to reconnect, or restart the phone. I give up. Probably time for a new phone anyway. Thanks again. – flloyd2010 Apr 24 '15 at 12:59
  • I think this answer doesn't apply to El Capitan -- there is no Storage section in System Preferences, when you search for Storage it highlights iCloud now. Weird. – jcollum May 3 '16 at 15:43
0

Kies can get a little complicated, you can try Android File Transfer.

0

I solved this problem by using transferring the files between Google drive.

  • Android File Transfer didn't work for me either (Galaxy S4, Mac Mini running Sierra), but using the middleman solved my problem. – Monica Cellio Jun 18 '17 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.