I recently changed the battery of my phone, but in doing so, kept it without battery for some time. After placing the new battery, I discovered that the date and time had gone back to default.

I tried to set them both to update from the network but neither is updating. I tried turning the option off and on again but nothing happens.

I can, of course, set the date manually, but I am wondering why it's not updating by itself. The time zone is correct.

I'm using a Samsung Galaxy Pocket, Android 2.3 (Gingerbread).

  • Do you have root access on your phone? Dec 8, 2015 at 12:01
  • nothing helped, I set the time manually and then re-enabled the automatic; so one day, whenever it want, it will probably update the datetime itself if needed.. Apr 29, 2016 at 22:39
  • @zackygaurav If you know of a way to update the clock, with root access, could you please post it as an answer here?
    – Marc.2377
    Jul 8, 2016 at 23:22

6 Answers 6


try this:

  1. uncheck "update from network"
  2. set it to a wrong time (something that's clearly not right)
  3. close settings (not sure if this is actually needed)
  4. check "update from network" again (which should correct the time)

Try rebooting your device (shut down and restart)

If that doesn't work, try manually setting the date back one month, exit settings, check update from network and reboot your device.

On restart Android should check the network date, see it's wrong and reset the clock.

My tv box's suspend mode screws up the time every time that it's invoked because it either has no realtime clock chip or it doesn't have a capacitor or battery to keep it going. Usually rebooting fixes this)


Just set the time wrongly (manually), then turn on automatic date and time and go back to ...internet. I just tried it (now)


please try this method: set it to "update from the network". Then connect the device to data(internet). Then it will update time automatically. I tried this once.

  • 1
    Thanks for the help but it's not working. I tried like this: turned off both automatic update and internet. Then turned Automatic on, and then turned wifi on. Nothing happened. :(
    – Alenanno
    Jul 8, 2015 at 10:23
  • try by using mobile data.
    – Rahul Gopi
    Jul 8, 2015 at 10:29
  • Exactlly (like it wrote Mr. Rahul Gopi), but you need to wait few minutes connected to internet.
    – user177923
    Jul 22, 2016 at 18:19

It's possible for the Automatic date and time to be turned off while changing a battery or switching between power-saving-modes. To turn it back on, go to settings --> Date and time --> then make sure Automatic-date-and-time is turned on.


TL;DR: If you get an error about NET:ERR_CERT_DATE_INVALID that make your tablet stop working, try to set manually DATE and TIME (both) to current one of your timezone.

I was trying to fix my step-parents tablet (old Samsung one, SM-T2.0NU, Android 5.0.2) that stopped working suddenly I was told while on YouTube.

Problems noticed, actions taken, etc. (you can skip to solution):

  • I had NET:ERR_CERT_DATE_INVALID error in Chrome. Noticed that some website worked (non-https ones and some others it seems). Most of the things was not working, like accessing Play Store. Without any meaningful error message, just an option to "retry".
  • I thought it was the internet, etc. So I rebooted router, tablet, removed everything Wifi, disconnect/reconnect, tried to set internet to manually (but it did have an IP automatically), etc.
  • Cleared Chrome history, cache, etc.
  • Automatic date and time option was not showing, but I could see the option by using the search, but when I tried to tick it, it bring me to date and time and was not applying any solution.
  • I tried multiple time to put the time myself...


  • Only after an hour trying to apply gazillion of solutions did I try to put the date in the past to notice the date was already 3 months behind (why? no clue). Then I set it to today's date and everything started working again.

I don't know if this will trigger the automatic management of date and time (I still cannot check the box even through search in settings), but I might not be the only one falling here to try to fix that issue that was preventing us using the tablet normally (I believe security settings verified that date and time were correct and I saw a lot of people having the same issues without a fix).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .