2

I have a Nexus 7 (2013) shipped with Lollipop 5.1. I downloaded the 4.3 factory image from https://developers.google.com/android/nexus/images and flashed it on the device. But after reboot, it just stuck on the Google's logo screen. I tried to search the solution, but didn't find one.

Please help. Thanks.


Updated 1: Just for test, I downloaded another several different factory images after that, which are 4.4, 4.4.4, 5.0 and 5.1. Finally, I found all images below 5.0 can't work on my device.

I flash the image just by running "flash-all.sh"


Updated 2: I also noticed there're some errors in the recovery mode. Here's the screenshot enter image description here

I discovered there's a similar question with me Nexus 7 Error: Failed to mount /cache. I tried with "fastboot format cache" and "fastboot erase cache", but doesn't work for me.

  • Did you ever find a solution? I'm experiencing an almost identical problem, except that now I can't even flash a 5.0 stock ROM (which worked fine last time I tried, around a year ago). – abeboparebop Nov 30 '16 at 21:28
  • Unfortunately I didn't find the solution. Instead I used another device eventually. I searched a lot on the internet, someone said it's the hardware's problem. But I can always flash back to it's original firmware. – popo Dec 1 '16 at 8:59
0

I was able to successfully resolve a very similar problem with my 2013 Nexus 7. However, I have not actually confirmed that it works with an Android 4.X stock ROM yet.

I discovered that my system default fastboot command (located at ~/bin/fastboot) was a symlink pointing to an executable fastboot-mac from the CF-Auto-Root package. (I must have made this change a long time ago for some other purpose and forgotten about it.)

The solution was to change the symlink to point to the proper fastboot executable located in my android-sdks directory. I then flashed a 6.0.1 stock ROM (MOB30X specifically) using flash-all.sh, and after 10 minutes of the Marshmallow boot animation, it successfully booted into Android. (Flashing the same stock ROM using the same procedure had not worked previously.)

I have a bit of evidence that suggests that this change was actually important, in addition to the fact that it worked this time. In the previous flash attempts with the old fastboot-mac executable, the flash-all.sh log messages included the following:

erasing 'cache'... OKAY
rebooting...

However, they did not mention that the cache partition was actually rewritten at any point. The new fastboot includes the log messages:

erasing 'cache'...
OKAY [  0.026s]
sending 'cache' (10984 KB)...
OKAY [  0.375s]
writing 'cache'...
OKAY [  0.466s]
rebooting...

which explicitly says that the cache has actually been rewritten.

  • Note: I had also previously used TWRP to change the /cache and /data partitions to use the f2fs filesystem instead of ext4, which seemed to get rid of some of the error messages in your question. However, I don't think this actually helped, because I attempted multiple unsuccessful flashes after this change. – abeboparebop Dec 1 '16 at 11:51
  • After 10+ unsuccessful flashes and 1 successful flash, I'm too concerned about being left with an unusable tablet to try again with a 4.X stock ROM. But if you try this, please comment to let me know how it goes. – abeboparebop Dec 1 '16 at 11:53
-1

Boot to recovery.

Backup everything you need using MTP Usb connection.

Wipe system, data, cache, and dalvik.

Flash the image again.

  • Yes, I just used flash-all script within the factory image package and flashed the whole images. – popo Nov 27 '15 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.