0

There is very little documentation available for the ADB driver. I started off trying to install the official thing. No clue on if you are supposed to install the driver listed on the same page first/last/at all. And their documentation starts you off in a "Choose an Option" screen I have never seen before, and have no idea how to get to.

My device manager recognises the table, and calls it by name, but the installer cannot ever find the device.

Moving on to the 15 seconds ADB Installer. Well everything appeared to work, but I do not notice any changes. Am I supposed to see a newly installed program, to open up the ADB command line thing? How do I know it installed, and use it?

Notes: Using Galaxy Tab E/Windows 10 x64

3

There is always a lack of documentation because the drivers are device specific so you need to find documentation for your specific device.

You can try using Universal ADB Driver, but the best solution is to install a companion app for your device, something like Kies for Samsung, as they usually install drivers alongside.

To know if ADB is installed - it's installed with Android Studio/Android SDK and you can type "adb devices" in command line and see will it return that the command is not found or will you get an actual response from adb.

  • OK, ADB is installed. But I have installed everything, and it never recognised the device. – Jonathon Dec 3 '15 at 17:40
  • Did you enable USB debugging in Developer options? Settings > About > tap 7 times on Build number > back > Developer options > USB Debugging Then, connect the phone to the PC, and while connected, type in command "adb devices", it will start the adb service and a prompt should pop up on your phone where you need to accept the RSA key from your PC. After that, you should be connected. If it doesnt happen, try rebooting your phone and redoing the command on your PC. – Chapz Dec 3 '15 at 17:48
  • I had not, never seen such a thing in all the adb installation guides I had yet seen. And it WORKED. – Jonathon Dec 3 '15 at 18:22
  • But it is still not working right. Keep getting permission denied errors, and I think the adb is supposed to have root access (somehow). – Jonathon Dec 3 '15 at 18:33
  • Of course. ADB doesnt grant you root access on your device. You need to root it first using some of the methods available for your device. After you get root you can use "adb shell" and "su" to get root access over ADB. – Chapz Dec 3 '15 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.