3

I have a completely successfully rooted Nexus 6p running the tawin project. I checked many tutorials on how to flash the xposed file via recovery, but every time it comes up with an error stating that the updater process has ended with an error installing zip file. I have no idea why this occurs and am pretty sure the correct file was installed. How can I be able do do it?

install error device details
install error / device details (click images for larger variants)

  • 1
    Why are you not using the official ZIP? dl-xda.xposed.info/framework/sdk23/arm64 Edit: Oh, there's the error: no space left on the device. I had this problem in Nexus 6. It had only 14.xx MB space in system partition, so Xposed didn't install (though it was enough BTW). I removed some unnecessary stuff (APKs) and everything went smooth. Make sure you make backup before removing anything from system partition. – Firelord Apr 24 '16 at 14:26
  • 2
    See the last line before the red block: cp: write error: no space left on device. Looks like your /system partition is full. – Izzy Apr 24 '16 at 14:27
  • i don't know why it says that since I still have a lot of space on my device. I tried putting the file into a different location and it said the same thing. – Devin Ersoy Apr 24 '16 at 14:30
  • You need space in system partition, not in any other partition. Check the status yourself using df command. – Firelord Apr 24 '16 at 14:30
  • ok so how do I delete the files in the system partition? – Devin Ersoy Apr 24 '16 at 14:32
2

Based on the screenshot, there's an error saying cp: write error: no space left on device. It seems there's no space in /system partition of the device.

Flashing Xposed Framework would make use of the device's /system partition.

In case there are apps or anything bloating up the /system partition, try removing them and freeing some space from unused apps, and then re-flash it again with a recovery program like TWRP or ClockworkMod.

Before reflashing, do wipe the cache/Dalvik cache first. Whenever the errors appear after flashing, wipe the cache/Dalvik to be sure it's clean before flashing again.

  • I downloaded 'system app uninstaller' from Play Store, and then uninstalled some Google's apps, it solved it! – Yang May 31 '17 at 7:29
  • Even without system app uninstaller, only uninstalling some "bloatware" apps would do just to make room for some free space. – warfreak92 Oct 26 '17 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.