0

I have a Samsung S6 running Android 6.0.1. There is a guest WiFi at work I signed into one time, and now can't get rid of:

  • I have tried to "forget" it.
  • I have turned off smart network switch.
  • I have turned off all wifi advanced options including "Passpoint" and "network notification" and have tried to turn WiFi off completely

I have done everything possible and it still autoconnects, even if I turn WiFi off within seconds it still tries to connect and drains my battery. When I get home it doesn't auto connect to my house WiFi but sometimes when I'm not even at work it will still try and connect to this guest wifi.

Is this a defect or am I missing something? Is there anything else I can try to get rid of it?

  • Does "everything" include having turned off WiFi altogether? I'd really wonder if it tries to connect with WiFi off. Apart from that, to know what options might be available it would help to know your device and Android version. Please edit your question and add that. And while on it, please explicitly list each WiFi option you've triggered ("all wifi advanced options" is a bit vague, as is "everything possible"). Thanks, and good luck! – Izzy May 28 '16 at 9:09
  • Thanks a lot, Stephanie – much clearer now. I've pimped the formatting a little to make it easier to read. What makes the issue really strange is the fact it even tries to connect while WiFi is turned off completely. That shouldn't happen at all. Especially not if that WiFi isn't even in reach. After you chose to "forget it", it should never try to auto-connect until you reconnected it manually. So it definitely is a defect, though it's not clear what kind of. Can you name your device and the Android version it's running? Also, did you install anything while on that WiFi? – Izzy May 28 '16 at 20:07
  • Thank you for all your help. It is an Android 6.0.1 Galaxy s6, of that is what you meant. And no I did not install anything. It was an hour free kind of guest wifi. – Stephanie Partlow May 28 '16 at 23:05
  • Wish I was helping with some more success… In Settings › WiFi › Advanced, have you ticked off the network check when WiFi is disabled? Not that should play a role here, but who knows. – Izzy May 28 '16 at 23:09
  • I dont see that as an option in advanced settings. I will try and find that setting and see. Thank you – Stephanie Partlow May 30 '16 at 16:21
1

Do you have any app that auto connects wifi, like tasker or Samsung's new application called 'Good Lock'? Because Good Lock creates routines and by default if it gets in some predefined location than it starts wifi and some other services. (sorry, I don't know if this can be termed as answer or not. But my reputation is low so I cannot comment and I just thought Good lock can be creating confusion)

  • Not that I am aware of, not the ines you mentioned, but thanks for the tip. I will check if any of my apps can do this. – Stephanie Partlow May 30 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.