1

I just bought a Nexus 6p a few days ago. I put TWRP and Cyanogenmod 14.1 on it. It was fine, until I wanted to try another ROM. So I booted to TWRP, and wiped it. I wasn't thinking when I wiped and now I don't have a ROM to flash. I want Resurrection Remix ROM. How can I fix this? I am really worried. Any help is greatly appreciated. If you need any more information just ask, I will gladly provide more if I can. I am open to installing any (safe) custom recovery, and any ROM at this point. Also, where is a place on the phone that does not get deleted when I perform a factory reset, so that I can always have a backup in case this happens again.

Thanks for any help!

I forgot to add: When I try to use fastboot update rom.zip I get this: Error image

0

Boot into TWRP again, choose "Advanced-ADBSideload", connect to PC, then adb sideload path/to/your-rom.zip (just open a command prompt window for this, and drag the zip file into the window to have its file name and path entered automatically).

  • 1. I asked where on the phone, and 2. For some reason the adb sideload is not working. It doesn't recognize my phone. – Tyler Richardson Dec 11 '16 at 1:26
  • My bad (facepalm)... Internal storage doesn't get wiped on factory reset, but you intentionally wiping it doesn't help. Aside from that there's nowhere safe (from flashing) and large enough to hold stuff permanently. – Andy Yan Dec 11 '16 at 2:04
  • What about regular ADB, i.e. if you plug it in when the phone is not in sideload menu? It should be recognized as "xxxxxxxx recovery" in adb devices. If that doesn't work either then grab a USB OTG adapter, TWRP also supports that. Or just flash a factory image via fastboot and start over (you already wiped everything so no worries about data) if you don't want to buy anything. Plenty of options still. – Andy Yan Dec 11 '16 at 2:05
  • That didn't work. Do you know where I could get ClockworkMod for the Nexus 6p? I have searched everywhere and simply cannot find it. I have found a link to CWM for the Nexus 4, and I tried changing mako to angler and I got an XML file saying Access Denied. – Tyler Richardson Dec 11 '16 at 2:55
  • CWM/PhilZ is dead long ago, don't bother. Keep trying the other options. At least your bootloader is unlocked (don't ever re-lock it), so it's not a dead-end. – Andy Yan Dec 11 '16 at 3:05
0

I figured something out. Windows 7 did not work for me. I had to boot into Linux (I use Debian 8).

Go to https://developers.google.com/android/ota and get the file for your device. This will be just the stock ROM. You will use this to get the ROM you actually want onto the phone.

This will be a ZIP file. fastboot update file.zip didn't work for me. If it worked for you, skip to the next paragraph. If it didn't work for you, just keep reading. Unzip the zip file, and manually flash all of the *.img files. They are named with the partition they go with. Ex: fastboot flash boot boot.img, fastboot flash system system.img. This should work.

Now boot into the stock ROM you just flashed. Don't worry about personalizing it. Get just what you need set up. If you have internet on the device, go ahead and open the browser and get the ROM that you want. Put it in a place you will remember or can find. Reboot into TWRP and hit Install. Find the zip file you just downloaded and flash it. You are done!

If you don't have internet, find a computer that does have internet and find the ROM that you want and download it. Move the file to the phone, and then flash it from TWRP.

That's what worked for me!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.