1

I wanted to update my OnePlus 3 to OxygenOS 4 using TWRP but that resulted in an error. I tried again, same error. I flashed the old image again, no error, phone was usable again, updated TWRP, flashed the new image again, different error. I then flashed the old image, again, no error.

However, my phone isn't usable right now because I can't unlock it. I definitely remember my pattern, I had it since I bought my the OnePlus 3 and I bought it right when it came out. I have to enter it every time I reboot so I entered it several times just today and there is just no way I remember it incorrectly. Furthermore, I have a second phone with the same pattern. I drew it on both phones simultaneously and only the other phone unlocked.

How can I log into my phone, again?

2

Note that @dan-brown seems to be right about the root cause of the issue - it looks like a corrupt install after flashing a new TWRP.

However there is a non-destructive fix, as documented here.

  1. Boot into recovery
  2. Navigate to /data/system
  3. Delete the following files:
    1. password.key
    2. pattern.key
    3. locksettings.db
    4. locksettings.db-shm
    5. locksettings.db-wal
  4. Reboot
  • Thanks. I accepted this answer because it looks promising but I can't check it as I reset my phone. – UTF-8 Jan 24 '17 at 8:04
  • This method definitively works, as long as you can decrypt&mount the relevant partitions in TWRP. – Irfy Oct 26 '17 at 20:41
0

This is a Bug I've encountered on all my devices in the Past three years. It comes from a minor fault in installing, and Is CyanogenMod/CyanogenOS based. Essentially, some partitions have become unstable. When this first happened to me, I (like you) had a scrambled pattern- even though I used a PIN. The second time, My phone could not delete anything. The third time, Everything was inverted. The list goes on.

Thanks for the Bedtime Story, but how do I fix it?

Well, this error normally comes from a dirty flash,but can be fixed with a factory reset (Tell TWRP to Wipe Data, Cache and Davlik) In some Cases, A CLEAN install of your OS is needed. Have ye Full stock ROM/Nandroid backup on an external SD, Do the factory reset, then wipe /system, then install from SD. If all goes well, problem solved!

  • Will wiping Data delete the contents of the emulated SD card? (Phone doesn't have a physical SD card.) – UTF-8 Jan 2 '17 at 22:11
  • Yes it will. If you need to do a clean install, use the NORMAL FACTORY RESET in TWRP (Saves ye pics and downloads, while wiping what matters I.e. apps) TWRP will say that it won't delete some stuff, but only on the right menu. If you have to type, its the wrong menu. – Dan Brown Jan 2 '17 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.