2

On Samsung Galaxy J7, I accidentally set "never allow" in sending premium messages. Now I can't activate some services directly.

I searched and found that Samsung Galaxy S phones have a setting called "Premium SMS", but there isn't anything like that in J7, either on:

  • Settings - Applications - Application manager - Messages - Permissions, or
  • ... Permissions - More - All permissions

How to change the setting for premium SMS on Samsung Galaxy J7?

  • Search for premium SMS access in Settings. Keep your search string minimum. You should find it. – MANI Jan 27 '17 at 14:50
  • There is no word as premium sms in settings. That is the problem. – user2431205 Jan 27 '17 at 15:14
1

On one case, it is showing under Apps - Special Access - Use Premium text message service, and it can be set to "Always Allow".

However, there is also a case where the messaging service does not show.

| improve this answer | |
0

There is no such option on the J7. When you go to more and click on each option, it only describes those options, no way to add any more. Also premium messages is not listed under more.

| improve this answer | |
0

Settings > Apps > Special Access > Use Premium SMS services > Switch to ‘Always Allow’

| improve this answer | |
0

Just go to Settings > Application > Application Manager > More (from top-right hand corner) > Show System App (Android icons need to appear) > Message Service (Android icon) > Send Premium SMS > Allow Always.

| improve this answer | |
0

I found it in Settings > Apps > (triple dots on the right corner) > Special access.

screenshot for accessing "Special access" menu from Apps

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.