2

Hello I have the OnePlus 3T using Oxygen 4.0.3, Android version 7.

I am able to connect my iphone 5s, Macbook Air, iPad 4 and Toshiba Chromebook to the phone. All devices register as connected, the hotspot icon on the taskbar of the Oneplus is on, but I am unable to access the internet on any of the devices. I can connect by bluetooth but still no internet. I tethered to the Macbook with a cable, but no internet. Any ideas?

I use the same sim in my iphone 5 and can connect to thee mentioned devices easily and the internet works.

I've tried all the solutions listed in this forum but none of them work for me. So I'm guessing it is the OnePlus 3T is the problem? Any thoughts?

Thanks again Phillip

  • Any update on this? – i_raqz May 24 '17 at 23:26
1

I have personally tried this on OxygenOS 4.1.6 on my OnePlus 3, but the solution is the same for all OxygenOS 4.X.X devices.

Note: If you have ADB setup, USB Debugging enabled and the drivers installed, skip to step 7.

  1. Enable Developer Options in Settings > About phone and tapping on the build number seven times.
  2. Next, in Settings > Developer Options enable "USB Debugging"
  3. Connect your OnePlus device to a laptop or computer, and install the appropriate the appropriate drivers from the "CD/DVD drive" that was inserted, then reboot your computer.
  4. Download ADB and Fastboot for your computer from the Android Developers website
  5. Extract the folder, open Terminal and navigate to the extracted folder using

cd path/to/extracted/folder

  1. Type adb devices and accept the prompt on your OnePlus device.
  2. This is the actual command that matters:

adb shell settings put global tether_dun_required 0

  1. Enjoy tethering from your OnePlus device.

Source: OnePlus Forums

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.