The Samsung Galaxy S2 (GT-I9100) I have at hand was turned off after getting hot during standby. When trying to start it again, it was in a bootloop: Like usual, it first shows "Samsung Galaxy S2 GT-I9100", then shows the provider branding and then shows "Samsung". But at the time when it was normally asking for the PIN, it was again showing the provider branding and going into a loop.

It is possible to go into the recovery mode. Among other things (see below) it shows "E:Error in /data/log/recovery_log.txt (No space left on device)".

The phone was running the newest stock firmware (Android 4.1.2). (At least I’m quite sure it was the newest version.)

Is there something I could try to make it start again, without loosing any data? For example, it could be the case that it’s not starting because the /data partition is full. Is it possible to remove files from this partition when booting the device is not possible?

If that’s not possible, is it possible to backup all the data (including app data and the internal "USB" storage), without loosing any data?

It seems like installing a different recovery ROM makes it possible to backup the data. However, I’ve read that installing a different recovery on a S2 with a stock ROM will stop the system from booting. In this case it doesn’t boot anyway. But in case it’s possible to fix the problem by making space free on the /data partition, can the original system be restored?

Some things which I observed that may (or may not) be helpful:

The recovery mode says "Android system recovery <3e>" at the top and "# MANUAL MODE #", "-- Appling Multi-CSC...", "Applied the CSC-code : DTM", and "Successfully applied multi-CDC" in the middle, right over the out-of-space error described above.

When turning on the phone, the provider sends SMSs to everyone who has tried to call the number while the phone was off. Even though the phone is boot-looping, such notification was sent.

  • @alecxs If I understand correctly, the "internal memory" consists of two parts: a system part and a USB-accessible part. Will any of these be included in the backup? Which part contains the app data (I’m particularly interested in the backup of the WhatsApp messages)? It seems like I can restore the original system by flashing the original ROM. Is there a reliable way to find out which image I need? Are there any precautions to make sure I use the correct ROM and don’t override the data? Commented Aug 13, 2019 at 21:16
  • forum.xda-developers.com/showthread.php?t=3740526
    – alecxs
    Commented Aug 13, 2019 at 21:19
  • @alecxs The TWRP instructions in the link say that IsoRec has to to be flashed first. Does this work without deleting app and user data from the device? Commented Aug 13, 2019 at 21:25
  • you are right! seems installing twrp is not as easy as expected. try PhilZ-cwm it has -signed.zip which can flashed directly via stock recovery (mediafire/mega.nz links are working) forum.xda-developers.com/galaxy-s2/development-derivatives/…
    – alecxs
    Commented Aug 13, 2019 at 21:44

1 Answer 1


When a phone is constantly crashing without any changes from your side, getting hot, usually it has a more seriously reason. You should focus on how to get your data off the phone first.

The SMS availability notifications indicates that android is still booting, just the gui system_server is crashing. To avoid availability toggle Airplane Mode or remove SIM Card.

Your internal memory (mmcblk0) is probably near wear-out. This means it will switch from read-write access to a read-only mode (for some partitions or completely) and one day it becomes unreadable. So how is data stored? List of partitions

EFS        /dev/block/mmcblk0p1
SBL1       /dev/block/mmcblk0p2
SBL2       /dev/block/mmcblk0p3
PARAM      /dev/block/mmcblk0p4
KERNEL     /dev/block/mmcblk0p5
RECOVERY   /dev/block/mmcblk0p6
CACHE      /dev/block/mmcblk0p7
MODEM      /dev/block/mmcblk0p8
FACTORYFS  /dev/block/mmcblk0p9
DATAFS     /dev/block/mmcblk0p10
UMS        /dev/block/mmcblk0p11
HIDDEN     /dev/block/mmcblk0p12

Typical important partitions on most android devices are BOOT RECOVERY CACHE SYSTEM USERDATA.

The BOOT (mmcblk0p5) partition contains the kernel and rootfs for the OS. It then loads the ROM from SYSTEM (mmcblk0p9). both partitions are read-only and can be downloaded everywhere (stock ROM). RECOVERY (mmcblk0p6) is a separate emergency rootfs. Samsung like to make things complicated, so in your case it is a recovery ramdisk which is included in boot. CACHE (mmcblk0p7) is a writeable partition for temporary files during OTA updates and log files. It can safely wiped/formatted any time. USERDATA (mmcblk0p10) is the only writeable partition for apps data, user installed apps and user files. However, seems like your phone has another additional writeable partition UMS (mmcblk0p11) especially for pictures and downloads (in newer android it is merged aka emulated storage), this is what you call USB Storage.

In android you only have access to pictures and downloads. the apps data is protected from user access and can only be backup with root access.

Modern android partitions are protected from altering, you can not flash modified content with a locked bootloader. Unlocking bootloader will trigger a factory reset, this is for security reasons to protect your data from unwanted access.

Luckily this is not the case for your device, the GT-I9100 comes from stock with unlocked bootloader!

The Android system recovery <3e> (stock recovery) gives you a very limited emergency access (sometimes with backup user data / restore user data) and wipe data/factory reset and wipe cache partition and apply update functionality.

So how to get access to your data? You can flash a custom recovery like TWRP from flash tool. This will not alter USERDATA or UMS partition.

Even more lucky, someone has leaked the Samsungs internal-only OEM signing key for OTA packages! (for older devices only)

PhilZ Touch Recovery CWM 6 comes as flashable signed zip which can be flashed directy from stock recovery.

This will (hopefully) bring you to custom recovery (if not, reboot to recovery mode). Now you can backup your /data and /sdcard -> to /external_sd

Once the backup is finished, perform a factory reset to see if this fixes your boot loop. factory reset will only wipe cache + userdata your stock ROM remains intact. If the phone is working, restore your backup and use adb shell in recovery mode to examine/delete your files.

If you managed to restore your phone, get off all your pictures via USB. consider a cloud backup of WhatsApp and other apps in google drive. This will help you to migrate your data to another phone before old phone dies.

  • Thank you for your detailed answer! I tried to apply the "update", but it fails with This package is for 'galaxys2,i9100,GT-I9100,GT-I9100M,GT-I9100P,GT-I9100T,SC-02C' devices; this is a ''. I could modify the updater script, but then I need to sign the update. Do you know how this is possible? Commented Aug 14, 2019 at 23:04
  • Unfortunately, I can’t connect via USB (I tried different modes, but my Linux kernel shows errors when plugging in the cable). Maybe the USB port is loose. Is there an alternative? Commented Aug 14, 2019 at 23:07
  • aliexpress.com/item/32837765368.html
    – alecxs
    Commented Aug 14, 2019 at 23:16
  • idk how to sign but the OP states it was done by chainfire. this is a temporary PhilZ-cwm (it does not flash recovery) it will only boot into PhilZ-cwm without modifying anything, maybe this one works forum.xda-developers.com/galaxy-s2/development-derivatives/… also it mention Aroma File Manager you could try inside recovery (use v1.8)
    – alecxs
    Commented Aug 14, 2019 at 23:28
  • It seems like only the data pins are not fully working. I was able to apply PhilZ-cwm6-XWMS3-FOP-5.15.9-signed.zip. I backuped /data and system, but I didn’t yet find out how to backup /sdcard (internal "USB storage") unfortunately. Commented Aug 15, 2019 at 0:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .