0

I was trying to install the factory software image from https://developers.google.com/android/images#blueline on my Pixel 3. I downloaded the image as well as the platform-tools with adb and fastboot.

After plugging in my phone, I ran "adb reboot bootloader" which put me into Fastboot mode. After this I tried to run the flash-all.bat file, but it was just stuck on the "waiting for devices" prompt. I'm not sure what I did at this point, but I must have really messed up the phone, because now I can't even boot from Fastboot, where clicking "Start" just puts me back in fastboot with the reason "no valid slot to boot." Any idea how I can get my phone working again?

I tried putting my phone in recovery mode, but I just got "error booting boot.img"

0

In this state I was just able to run "flash-all.bat" - which let me load. Not sure why it wasn't letting before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.