I have a zenfone 5 which used to run on custom rom so i decided to revert it back to stock rom but when i wiped system cache and dalvik, it didn't go well and now i cannot start phone unless going into recovery. Twrp tells me those errors : unable to mount cache unable to mount system

Tried flashing custom rom again but it didn't work too. Any helps please :/

ps: my phone's usb is not working as a connector to pc i.e. pc cannot recognise the phone. please keep this in mind.


It appears like when you first wiped your partitions, the process was possibly interrupted and you now have corrupt partitions which are not being recognised in TWRP.

  • Please go to your TWRP settings and make sure that the use rm -rf instead of formatting option is not checked.
  • Now go WipeAdvanced Wipe section and try wiping all those partitions again which are currently giving unable to mount errors. Then reboot into TWRP and try again.
  • It is recommended that you use a charger during the wipe process so that a battery failure will not interrupt the process.

Tried flashing custom rom again but it didn't work too.

Please post the error that you get while flashing or at least a part of the error that appears, so that your problem can be understood properly.

  • This is another similar answer which might be of help. Follow the steps if you're sure that your partitions were formatted as EXT4 before. – ManSamVampire Oct 10 '19 at 14:08
  • Thanks for your answer but i tried going into recovery now in order to show you errors but the touch screen doesn't work now. I will try again and post screen photos showing errors later. – orhan7 Oct 10 '19 at 14:18
  • 1) here is the error screen i get when i try wipe link 2) confirming the option rm -rf is unchecked 3) tried what you said and rebooted but nothing changed 4) will post flashing rom screen soon – orhan7 Oct 10 '19 at 17:42
  • tried ext4 option that you've linked but it didn't help too – orhan7 Oct 10 '19 at 17:45
  • Sorry about the late reply. I have also seen in some scenarios that this works - Change file system option → format the corrupted partition(s) to some other filesystem like exFAT or FAT32 → again reformat them to ext4. Also try using the Repair file system option to correct the corrupted file system. – ManSamVampire Oct 23 '19 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.