1

i just installed android x86 9.0c and i don't know why it doesn't boot on GUI mode and it boots only in commandline then after some seconds i can only see just a dash appearing and disappearing. I have tried to put my graphics settings to vboxvga and disabled 3D acceleration but it still doesn't work. What else i can do to fix this problem?

here you can see that its booted in commandline , after some seconds it becomes black and all i can see is just a dash appearing and disappearing

1

According to the answer here from Stack Overflow:

  1. Temporary fix: append nomodeset xforcevesa at the end of the line containing kernel during boot time at the GRUB menu. During boot press E to edit. While on the line containing kernel press E again, append nomodeset xforcevesa at the end, press enter, then press B to boot.
  2. Permanent fix: read the answer here.
1

This is a semi permanent fix. It will stay fixed until you open settings. Then you can just do it again.

1. On the main VBox screen in the display section click on what ever follows Graphics Controller:

2. In the box that opens select VBoxSVGA.

Here is a picture of the main screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy