2

I am trying to recover some files on my android device, but without success. So I would like to try tools like photorec, but they need a physically mounted device. Or rather, for the moment photorec makes me recover files only from /dev/sdx, so I need to mount the mtp device like this. For now I have tried this solution here: https://askubuntu.com/questions/446180/how-to-mount-smartphone-to-recover-files but jmtpfs gives me an error. And and lastly this Android system partition image on pc or sdcard. The problem is that in recent versions of android (I tried 10 and 11), in the block folder there is no stl6, but a lot of sdx partitions.

3
  • Cross-posted from Ubuntu.SE: askubuntu.com/q/1365727/331791
    – Andrew T.
    Sep 25, 2021 at 17:59
  • you cannot recover files from android device, I doubt photorec did recover anything
    – alecxs
    Sep 25, 2021 at 19:30
  • 2
    MTP exposes emulated storage, and that too as a file transfer protocol, not the storage itself. Recovering data requires access to raw userdata partition or the bare filesystem of the partition (mounted at /data): android.stackexchange.com/a/208114/218526. But on modern devices data recovery is extremely unlikely due to locked bootloader, encryption, and use of flash filesystem (f2fs). Sep 25, 2021 at 19:41

0

You must log in to answer this question.

Browse other questions tagged .