After I rooted my Samsung Galaxy S3 GT-I9300 phone, I was no longer able to connect to Kies to do a sync. Does anyone know why?

I have tried to reinstall Kies on my laptop, performed "Troubleshoot connection error", and deactivated USB-Debugging BEFORE I connected my phone for the first time. But the same issues remained.

When I performed *#1234# to view SW version, the PDA option was not one of the options there.

There are no issues with my USB connections as I have no problem downloading apps from Google Play on my laptop.

Pls advise how I can resolve this issue?

3 Answers 3


I couldn't connect my S3 to Kies and tried everything other users posted (usb debugging, scanning pc for viruses, etc...) and I stumbled upon the fix that solved my issue and I've now connected with Kies and have full functionality with Kies and no issues with my S3.


On the S3 device:

  • Pull down from top of home screen (swipe from top of screen downward) to the screen that shows (across the top) Wi-Fi, Bluetooth, etc...
  • Check to see how the device is connected "Connected as a Media Device" should be shown.
  • Mine said "Connected as a camera" and I changed that to "Connected as a Media Device" and instantly connected to Kies.

Hope this helps!


I realised that the problem lies with a MTP device driver which was not properly installed. All I had to do was delete all the drivers, including Samsung Kies, and reinstall everything again.

One of the other thing I did before the issue appeared, was installing SGS3 Easy UMS. Because I switched my phone from MTP to UMS mode, that prevented my laptop from detecting the phone. Switching it back to MTP, and reinstalling the above applications did help.

However, I would continue to encounter connectivity issues every now and then. For instance, after I plugged my phone into my laptop via USB, and switch to syncing using Kies Air, I would encounter an error message that says my USB is plugged in.

This could be easily resolved by restarting my phone.

I can only conclude that Samsung Kies developer probably didn't do a good job handling socket connections, resulting in the error above.


I had the same problem after rooting my S3. The solution is easy: just unroot your phone and like magic your old driver will work correctly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .