I have bought a Samsung Galaxy Ace few days back. And it's showing network / connection problem or error, or connection time out. Whenever I try to open a page it shows "Webpage not available". And just to check whether the Internet is working properly or not, I have activated the 'net pack, still it's loading, loading, and loading but not opening the site. Google home page is opening but after Google not even a single page is opening. Samsung applications are also not opening. It shows network error. Google play store is having the same problem. Please help.

  • So in simple words, your phone is not connecting to Internet. Did you check your network settings? Call your service provider's service center to get these settings. They should send a settings message, or manually enter APN, host, etc. Make sure the APN, host, port, password, all details are correctly entered. And please, avoid using shorthand "SMS lingo." Someone will have to spend time editing it. Commented Nov 25, 2012 at 13:07

1 Answer 1


Don't worry as the device is new you have warranty, do a factory reset and see.

  • 1
    Factory reset doesn't seem to be a solution here. What's the point in loosing the data for a connection issue? Commented Nov 25, 2012 at 13:09
  • @SurajBajaj, did you read the question completely, before using Service Provider's internet there is a network connection problem. So a reset will delete all settings and again Service Provider will send settings then it may work, also the question is incomplete which net she used before using service provider's, static IP not set may be.
    – N Khan
    Commented Nov 26, 2012 at 6:55
  • Yes, I read the question and also edited it myself! :) Factory reset still doesn't make any sense to me. It doesn't just reset your settings but also wipes all your data! Instead just tweaking Network Settings will help. And yes, I didn't down vote, so calm down! Commented Nov 26, 2012 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .