So my nexus 4 is rooted and unlocked. Well actually Im not sure, because after updating with the OTA it seems to have lost that capability. Even though there are SU Binaries still there.

Anyway, I am trying to install Cyanogenmod Nightly, but I cannot get my phone to show up in my computer or Device manager. I have the drivers install and all. I have tried with usb debugging on and off. I have tried in the Fastboot mode. I have tried after a factory reset.

I'm at a lost as to what I can do....When I try to go to recovery it says "No Command" or something

SO strange,


BTW: I have tried two different win7 computers, same result

  • I have the drivers install and all. Which drivers from where? Have you tried the ones in the Android SDK? Although if it doesn't show up in Device Manager or Windows doesn't say anything about not finding a driver when you connect it, then the problem is either with the device or the USB cable (assuming it's not the computer's ports). – Matthew Read Dec 2 '12 at 0:56
  • yeah im thinking its the device too... it still charges though :/ I have tried two usb cables – thegreyspot Dec 2 '12 at 19:32
  • I know you have already said that you have USB debugging turned on, but can you please check again? Sometimes it gets turned off after an update. (Sorry if this is not the case). Also, yes I believe updating will "unroot" your phone.. – Raghd Hamzeh Dec 2 '12 at 21:18

I had a similar problem. My LG Nexus 4 wasn't listed in adb devices.

Make sure USB debugging is enabled from device, and do the following on your PC:

  1. Update Android SDK (Google USB drivers updated)
  2. From PC Control Panel, System -> Device manager -> Nexus 4 -> Install driver.
    Set Android SDK as path to search, include subfolders checked.

After that, adb devices list will include Nexus 4.


USB debugging must be enabled.

You will know the device is connected, because it will show when you type adb devices into a command prompt.

Ensure you have the correct drivers installed, the ones from Google and/or LG, and then reboot your computer. Once that is done, reconnect the device. You may need to delete it from the device manager before it will install the adb driver correctlty.

  • I dont see any phones connected when I run adb devices. I know i have the correct drivers installed because I unlocked and rooted the phone before from the same computer. The device is not even showing up in device manager, so I cant delete any drivers – thegreyspot Dec 2 '12 at 19:31
  • If you used it from the same computer, then it must be working. What happens when you type adb devices? Do you have adb installed? Is usb debugging enabled? – Liam W Dec 2 '12 at 19:32
  • Yes usb debugging is enabled, adb devices doesnt find any devices – thegreyspot Dec 2 '12 at 19:37
  • Does it just state: List of connected devices? If so, then this sounds like a driver issue, it could be that your connection has broke however. Does the device state that it is connected? – Liam W Dec 2 '12 at 19:38
  • Yes thats all it says. Should the phone state that it is connected? I dont remember if the nexus 4 does or doesnt :/ THe charge icon in the battery icon shows at least. – thegreyspot Dec 2 '12 at 19:46

Hold the power button until the phone turns off. Wait a few seconds. Then, turn it on, with the USB connected. Wait until the charging symbol appears. Then, turn on the phone.

Now, the Nexus 4 is showing in My computer again.

  1. Plug in your phone
  2. Go to Device Manager
  3. Look for Acer Device
  4. Expand that and you will see something like ACER Composite ADB Interface
  5. Right click and delete that
  6. Unplug and replug your phone and you should be able to get it.

Here's another tutorial if the method above doesn't work.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.