I recently installed Clockwork Recovery, and used that to install CyanogenMod 10 on my Captivate using this guide. Every thing worked perfectly.

I backed up the stock ROM. Then I realized that my contacts and data were gone in the new ROM. I read in an article that you could restore the data part of the backup using the recovery in Nandroid, so I recovered it. But when I rebooted, the phone got stuck at the spinning CyaogenMod screen.

I made the problem worse by trying to flash the mtkareys zImage kernel, and repeated the process described in the guide. Now, I can't get into recovery mode nor the Android (CyaogenMod) OS.

I suspect that I would need to use some tool that uses my Ubuntu 12.04 or Windows 7 PC, because the only resource that I have access to is download mode in the phone. Nothing else seems to work. Please understand that I am a beginner who has never even written an app for android (I do have the sdk installed though).

  • Why did you flash a kernel mtkareys zImage kernel to quote OP, when really you wanted to restore the data part of it...? What was the deciding factor in that?!
    – t0mm13b
    Commented Dec 27, 2012 at 17:42

3 Answers 3


What Izzy said is correct. Also, never give up! I found that there is always something you can do to unbrick your captivate.

The xda-developers wiki page is very useful in this regard. The sections about bricking and unbricking should be very useful. While it's very difficult to enumerate all possible ways of unbricking here, understanding the nature of the brick (soft or hard) and looking for alternative ways in the forums is always helpful. The techniques that I know of so far are:

  • The 3-button method and its variations, as listed in the wiki page above. (There are variations, just search for them in xda-developers)
  • Using your PC and the USB cable. Izzy's answer is one such method.
  • Hardware solutions that involve cutting a USB cable or using resistors. When you have a hard brick, you may have to resort to these.

Good luck and don't stop searching! There is always a way to unbrick your Captivate.

  • rather than just adding a link, please explain what the method is, with a summery of the article you have linked.
    – Sid
    Commented Jul 12, 2013 at 7:22
  • Thank you for your tip on how to write a more helpful answer. Unfortunately I do not have time to write a summary and I believe the information that I gave can be useful as is. Commented Jul 12, 2013 at 10:39
  • Turns out I do have time now. Hope this is better. I need 10 reputation so I can provide a better answer to this poor fellow. Commented Jul 12, 2013 at 11:17

If you had recovery, a simple data wipe would have fixed the boot loop issue. The issue you are describing sounds like a kernel/system issue.

The only fix would be to try and flash a new kernel via download mode - you would have to find a program that could do this.

If this isn't possible (it may not be), then you should consider your phone bricked, and you should take it to your nearest service center for repair (don't tell them you rooted it, just say it wouldn't turn on after you had turned it off).


That's a stack of errors occuring to you. Before I present you a possible solution, let me point out what your mistakes have been -- to avoid those in the future:

  1. Never ever go to restore system data (this includes SMS, contacts, and other data from system apps) from a Nandroid backup of one ROM to a different ROM. This might work in some cases (when those ROMs involved are very compatible), but most likely will bring you in trouble as it was in your case. Apps store their data mostly in SQLite files, which contain databases -- and the structure of those databases very often differs. So you break those apps, which leads to different kind of trouble -- up to the point of boot-loops or incomplete boots, being stuck at the logo. This is also why Liam is correct that a "data wipe" (or "factory reset") would have solved the issue (as it would remove those broken SQLite files, and the apps would re-create them emptily).
    If you really need to transfer data of system apps between different ROMs, the best way is to export this data before you flash (contacts can be exported directly from the contacts app, and would then be stored as .vcf file on your sdcard; for other things like SMS there are apps available on the playstore), and import them afterwards. Also, as you are rooted, you should consider buying the pro version of Titanium Backup for a complete backup (in addition to your Nandroid backup). Titanium Backup includes a "Migration feature" which should work for those kind of data as well.
  2. Never flash a kernel if you are not 100% sure it works for your combination of device and ROM. If you break things here, you device won't be able to boot in normal or recovery mode, as you experienced. Especially do no such thing if your device already has other trouble -- first solve that trouble before doing such "deep system changes".

Now, you are 100% correct: As you are no longer able to boot into recovery mode, you need a helper tool "from outside". For Samsung devices, this tool is either Odin (which is what Samsung itself provides), or Heimdall, which is a cross-plattform alternative to Odin which will also run on your Ubuntu PC (Odin will not, as it IMHO is for Windows only). Use either of the two to flash any ROM compatible to your device, so you get your recovery mode working again. Once that is done, you might start over flashing ClockworkMod recovery, then restoring your complete Nandroid backup, exporting your data as described above, and finally switch to the ROM you wanted to use.


  • Good luck! If that fails, give Heimdall a try. I don't own any Samsung device, but I've read quite often that Heimdall is to be preferred over Odin. The Whys and Hows for that are better explained by a Samsung user who can tell it first-hand, though ;)
    – Izzy
    Commented Dec 29, 2012 at 18:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .