I don't receive Gmail notifications on my phone recently, no sound, no light and nothing appears on the notification bar. Searching the web, I figured it might have happened because I turned syncing options off. So I turned it on except for some syncing options such as Pictures and browser. I still am not getting notified of new emails. What's wrong?

  • What Android version you are on? If 4.1 or higher: Check Settings->Apps->Manage Apps, look up the Gmail app, and make sure you don't have notifications disabled for it (yepp, one can do that with 4.1 and up).
    – Izzy
    Commented Jan 17, 2013 at 20:01
  • @Izzy: It's Android 4.1.1 but I can't change anything in the Gmail app.
    – Gigili
    Commented Jan 17, 2013 at 20:10
  • Thank you, that worked. But not from setting, from the setting of Gmail itself.
    – Gigili
    Commented Jan 17, 2013 at 20:11
  • Not inside the app -- oh, I see where I was confusing: Go to your homescreen (hit the home key), and from there go to the settings. I meant the Android settings, not the app's settings, sorry.
    – Izzy
    Commented Jan 17, 2013 at 20:11

1 Answer 1


Summing up results from the in-comment-discussion:

Starting with Android 4.1, notifications can be disabled on a per-app basis: Either by long-pressing a specific notification in the notification area, and navigating from there to the app which sent it -- or directly from the Android settings in Apps → Manage Apps, and selecting the app you want to disable notifications for: here you will find the possibility to allow/forbid an app to place notifications in the notification area. This is valid generally and for all apps, starting with Android 4.1.

As with the Gmail app, some apps also offer this option themselves (which then also works for Android versions prior to 4.1). You find it from inside the app, when visiting its settings page(s). But as said, this will vary between apps -- not all apps offer this option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .