I plugged in Nexus 4 to my windows machine(XP Service Pack 2) and it didnt recognise or install any software automatically. I downloaded Google USB Driver from SDK Kit and installed it and now it shows up as recognised device in the Device Manager, but how do I copy files to Phones Storage ? There s no send to option as its not connected as a USB mass storage(which is not there in this device as well)


The XDA article How To - Connect Nexus 4 to XP like MTP device describes the steps needed for Windows XP as follows:

  1. Connect your Nexus to PC.
  2. Go to My Computer>Properties>Device Manager and double click on MTP device
  3. Go to Details and copy (Ctr+C) info like (USB\VID_18D1&PID_4EE2&MI_00) (you can copy it from here too, if it is identically)
  4. Unplug Nexus from PC.
  5. Go to C:\Windows\inf folder (it's hidden)
  6. Find a file "wpdmtp.inf" and open it with any text editor (Notepad)
  7. Modify or Paste (Ctrl+P) what did you copy at step "3" as bottom I showed.
; Installation inf for devices supporting Media Transfer Protocol (MTP)
; Copyright (c) Microsoft Corporation.

Signature="$WINDOWS NT$"

MTP.Files.Kernel = 12
MTP.Files.XPRT_USB = 11
MTP.Files.Core = 11
MTP.Files.UMDFDDriver = 12,UMDF ; copy to system32\drivers\umdf
;Device is identified by Microsoft OS descriptor
;If your device does not support it, use specific VID & PID for identification
%GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
%GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4EE2&MI_00
%GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
%GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4EE2&MI_00
  1. Save and close the file.
  2. Connect your Nexus to PC
  3. Go to Device Manager and update MTP driver.
  4. Tick chekbox "Install the software automatically (Recomenden)" on driver installation dialog and install driver. Wait for a moment and you can see Nexus 4 like an MTP device.

Now you should see the MTP device, and be able to transfer files to it.

Hope this solves your issue :)

  • Yes this helped, but I got 2 problems, 1> File was nt there - So downloaded WIn Player 11 and it was solved. 2> I had installed ADB driver before, so when I uninstalled that and tried to install driver it always instalelled ADB driver instead of MTP. So instead I chose Manual Location and it gave 2 options install as ADB or MTP and I chose as MTP and all is good now :) Thanks for that link ! Didnt come across that link while I was googling, – user88975 May 11 '13 at 16:06
  • Glad it helped -- and thanks for the updated details! – Izzy May 11 '13 at 16:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.