3

When I connect my Samsung Galaxy S4 (Verizon) with a USB cable to my work PC that is running Windows 7, my work PC recognizes it immediately. I see all my pictures, music, etc.

When I connect my phone to my home PC which is also running Windows 7, I get a device named "CD Drive (F:) Verizon Mobile". I see a very short list of folders and files that includes a USB driver (with an autorun) and a few Mac OS folders in it. In Device Manager, this shows up under DVD/CD-ROM drives" with a driver named "SAMSUNG File-Stor Gadget USB Device".

After a few seconds of looking at these files, Windows removes the device and replaces it with one labeled "SCH-I545". Clicking on SCH-I545, there are no files visible. I have many files and photos on my phone, but I can't see any of them in Explorer. If I right-click SCH-I545 and get Proeprties, I see a battery level, but nothing else.

Opening Device Manager, I see SCH-I545 in the list of portable devices. The manufacturer of this driver is Microsoft. I have tried uninstalling the driver, unplugging the phone, and plugging it back in, but the same thing happens.

I have tried downloading and installing the USB driver from the Samsung site, but the same thing happens.

I have managed to get Samsung Link working to load some files onto my phone, but I would much rather use a file copy mechanism.

Does anyone have an idea of how I can get my home PC to recognize the phone and let me copy files to and from it?

  • What are these drivers you installed? Is it from Samsung Kies? – geffchang Aug 15 '13 at 16:02
  • Most, if not all, devices are treated as CD device initally, that is to enable to install the driver from the device, once installed, it switches to another USB mode, that is, a drive with your files on it. What Android Version? What mode is it in, MTP? – t0mm13b Aug 15 '13 at 16:14
1

After searching the Internet for similar issues, I did the following:

  1. I unplugged my phone from the USB cable.
  2. On the home screen, I pressed the bottom left Settings button and chose Settings.
  3. I selected "... More".
  4. I pressed "Developer options" in the list below.
  5. I turned on the Developer options at the top.
  6. Under the Debugging section, I checked "USB debugging".
  7. I reinstalled Samsung Kies.
  8. I started Kies.
  9. After Kies started, I plugged in my phone to the USB cable.

After connecting my phone with Kies running, the Windows Update form appeared and a new entry was in the list. After the driver installation, everything worked. I don't even have to run Kies first before connecting my phone to get Windows 7 to recognize it. It just works.

I don't know exactly what series of events caused this to start working, but now I can actually copy stuff to and from my phone. (Yay!)

0

When you connect your Galaxy S4 to the PC via USB, open the notification center and you'll see a message that says something like Connected to USB. Click for more options. Click it, and then select View as camera. After that you, should be able to copy files from the PC to your phone.

protected by Community Jan 24 '14 at 10:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.