1

I have a HTC One X (not rooted) running Android 4.1.1 but unfortunately it keeps disconnecting from my router when I am at home. The router in question is a Buffalo AirStation WZR-HP-G300NH2 running DD-WRT and the issue occurs even when I am less than one meter away from it. The phone shows the WiFi signal as full strength, but most of the time it will constantly disconnect and reconnect.

The router is running in 802.11g/n mixed mode at 2.4GHz.

Here's the thing: the phone was previously working fine with my network for several months yet nothing has changed that I am aware of and I have not updated the firmware of either device in some time. I still have no problems connecting to my neighbour's router (which I have been granted access to) from the same phone even though the signal is understandably poor. Also, no other devices have trouble connecting to my router.

My router was configured to choose a channel automatically. Using inSSIDer on the phone I could see that the router was picking channel 6 - this seems to be logical as there does not seem to be anything else using it. I manually set the WiFi to channel 6 to be sure, but the issue remains.

I'm having trouble working out whether the phone or the router is to blame. I'm guessing that there could be some kind of interference on the channel I'm using, but I don't want to change to another one because no other devices have a problem using it and I'm guessing that performance could be reduced due to interference from other networks.

Any help in diagnosing the problem would be appreciated. Both devices have been restarted yet there was no improvement.

  • Have you tried restarting the router? Maybe it got "instable". Are other devices connected to it, and do they show similar behaviour? – Izzy Sep 24 '13 at 11:19
  • @Izzy: I have restarted both devices but there was zero improvment. I have an old iPhone 4 which connects to the same network flawlessly. – James Sep 24 '13 at 11:31
  • OK, thanks for clarification. One more thing to try: a different channel. Just to rule out that might be the cause (I doubt it, but better be sure). – Izzy Sep 24 '13 at 13:12
0

Ironically the Android 4.2.2 update I had been waiting many months for turned finally turned up the day after I posted my question. Since I updated I haven't seen the problem occur again so I'm hoping it fixed it. On the other hand it might just be a coincidence so I'll have to see how it goes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.