I have made several searches across many boards but failed at finding a solution for my problem yet, even though it's been reported by some.

My phone was working fine for about a month, I was using the mass-storage technique without a problem until it stopped working one day.

Now, when I plug in my phone by usb to any computer, the connection screen will not come up, the battery charging icon sometimes fails to appear as well and I can hear the computer detecting a new device but it will not recognize it.

I did a hard reset on the phone, which ended up in 2.1 instead of the 2.2 i had, and the problem persists.

I have tried everything, from usb debugging mode to uninstalling/reinstalling drivers, even tried with my friend's cable and it does the same thing...I am very frustrated!

Anybody got a fix for me?

  • Can Kies see it? Feb 2, 2011 at 4:53
  • no, even though I have never used Kies (I prefer mass-storage liberty), I have installed Kies while troubleshooting and there is no detection whatsoever (I guess it would have worked before, back when it was working in mass-storage)
    – user2655
    Feb 2, 2011 at 4:57
  • Have you tried other data cables? Have you tried that cable with other devices?
    – Matt
    Feb 2, 2011 at 9:38
  • yes as stated, i have tried with my friend's cable, which he was using just before, and it did the same thing
    – user2655
    Feb 2, 2011 at 20:35
  • actually, Ive had exactly the same problem, using vista. Initially when you download Kies and then install the drivers, it works for a while in the pc mode. kies just won't detect the phone, but another window comes up which asks you to either scan your drives or do nothing. I have not bothered resetting the phone back to factory settings. Im now going to try on another computer.
    – user3123
    Feb 24, 2011 at 22:41

4 Answers 4


How do you know it is not a driver problem?

You've tried different cables? hopefully one that is confirmed to work with another phone.

Have you tried a different computer?

If its still dead to USB- then it sounds like a hardware issue with the phone, if you're under warranty then take it back!

  • It is not a driver problem because everything was working fine on my home and work computer until the problem occured, now it wouldnt work on neither of them. I have tried my friend's cable, the one he is using for his Android phone and which is confirmed to work. I guess I'll have to try calling Samsung. Scary.
    – user2655
    Feb 2, 2011 at 12:56

Turns out my center pins (2 and 3) on my Galaxy S were dirty. Try cleaning the port (or plugging in the cable many, many times)

See this question for the description of the pins Micro USB cables that only charge but no data, no mounting etc (Samsung Galaxy S)


Maybe this will help you thanks, to My Samsung Galaxy 3 (GT-i5801) is not being detected by my PC -- What should I do?:

  1. Unplug the USB cable
  2. On the cell phone, dial the following number: *#7284# Once the last

    is hit, the PhoneUtil application is launched. Choose USB -> Modem and then USB -> PDA mode. The good mode should be PDA. Even if the

    mode is PDA, switch to Modem and then back to PDA.
  3. Plug the USB cable.

I hear these symptoms quite a lot from the Galaxy S: USB charging does work, but the Galaxy S does not get recognized and no USB data connection (mass storage, debug, etc.) is established.

This seems like a hardware design flaw, which hopefully got fixed with newer models. I think you should return your phone and have it repaired.

You must log in to answer this question.