2

Yesterday I have updated Google Drive and installed Sheets. Since that time I am unable to open the spreadsheets I have created earlier.

When I try to open a sheet, I get Unable to access document. Please make sure that you are connected to the internet. I am obviously connected, Firefox works, I can even open documents, just not sheets.

If I try to set offline access to these sheets, they keep downloading, just like when I have no internet connection.

Anyone else has this problem, or even better, a solution? I have tried clearing the cache of Drive an Sheets, did not help.
I have a rooted Nexus 4 with 4.4.2

  • You can access your Drive spreadsheets from within Sheets once logged in. – aureljared May 23 '14 at 6:12
  • Logged into what? I need to have an account to even download Sheets from google play, so how much more logged in can I be? – András May 23 '14 at 8:21
  • 1
    No additional login is required for Sheets. It already uses Google Auth. @András, this sound a little silly, but have you attempted uninstalling+reinstalling and/or clearing the data cache from both Sheets and Drive? – filoxo May 23 '14 at 14:15
  • @András Into Sheets, but you don't need to do that. Sorry for the misunderstanding. – aureljared May 24 '14 at 7:16
2

Used to have the same problem. In my case, google drive was trying to open the document using Sheets app, but the Sheets app was allowed to access documents only via WiFi connection. Go to Sheets/Setings and uncheck "Transfer files only over Wi-Fi" checkbox. Be aware, that similar "Transfer files only over Wi-Fi" checkbox is also in Drive app, but this affects only Drive app, not the Sheets app.

0

I just upgraded google drive and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.