I have a T-Mobile G1/HTC Dream, rooted, running CM6. It froze up at the lock screen, and after trying everything I popped the battery out and rebooted. However, this didn't solve the problem; I still couldn't get past the lock screen. After rebooting again (via battery removal, because nothing else worked), I only get a black screen (LCD on but blank). The problem seems different than other questions here on the site because I don't ever see the T-Mobile splash screen. I've tried Home+Power, Call+Menu+Power, Camera+Power, and none of those combos have allowed me to boot into recovery or factory reset, I still just see a black screen. When I plug in USB, the computer does not see the SD card.

Update: Now the LCD doesn't turn on either. Perhaps this is a problem with the ribbon after all? But that doesn't explain the freezing/booting issues.

Update: Although I only get a black screen, the phone does vibrate when I turn it on (using any of the key combinations mentioned above).

  • Here are some related sites and questions, but none of them have fixed this. I am a newbie, so it is very possible I've overlooked something obvious! the-dro.com/technology/g1-stuck-on-t-mobile-bootup-screen
    – Mingo
    Mar 31, 2011 at 1:39
  • This is also a related question: android.stackexchange.com/questions/2289/…
    – Mingo
    Mar 31, 2011 at 1:42
  • Also related. It's possible the ribbon for the screen died, but because of the lock screen issues it seems that this might be a software issue. forum.xda-developers.com/showthread.php?t=462910
    – Mingo
    Mar 31, 2011 at 1:52
  • Situation is worse for me, as I can't access even the boot menu. My device doesn't even start, let alone access boot menu. I tried everything, from charging getting my phone in the right hands, changing batteries, all that. It's as good as paperweight foe me. I think G1 is quite sensitive, in that, you could destroy it by the slightest touch of the wind. I don't think I'd recommend getting this one to anyone, since it's bound to destroy itself in a year or so, if not a month.
    – user38061
    Jul 23, 2013 at 6:50

2 Answers 2


Since you have CM6 flashed already, try booting the phone into the bootloader (fastboot). If you can get in there, you can rescue your phone with fastboot erase cache; If that doesn't work, reflash CM6. This will cost you your data that's not on the SD card.

Opinion: Having had a bunch of G1s (all secondhand), they are not the most reliable phones I've owned. I have had one turn into a brick (permanently!) after leaving it in a hot car (next to my Magic, same chipset, which survived) for 30 minutes.

  • Ok, newbie question, but I think the info should be here for future reference - how do you get into fastboot?
    – Mingo
    Aug 2, 2011 at 4:04
  • On the G1, hold camera (all the way in) and press power.
    – Broam
    Aug 2, 2011 at 14:09
  • Tried it, won't boot. I think it's a brick. Oh well, thanks everybody for the help.
    – Mingo
    Aug 3, 2011 at 11:47
  • Boo. It happens, unfortunately. If you were seeing the "G1" fastboot is almost guaranteed, but with a blank screen before the logo it was a crapshoot.
    – Broam
    Aug 3, 2011 at 18:01
  • One last thought. Hold the trackball in and press power. If you get a blue LED, there's (faint) hope, but otherwise, sell it on the auction sites because the screen is still good.
    – Broam
    Aug 3, 2011 at 18:01

Do a Dalvik cache wipe. Check the last paragraph of the following blog post http://www.olafusimichael.com/2010/09/how-i-flashed-my-htc-dream-t-mobile-g1.html

Sorry for the short answer, but it should fix the issue.

  • Thanks for the help. Only problem is, I can't even boot into recovery mode of anything in order to wipe the cache. Booting the phone just shows a black screen.
    – Mingo
    Jun 2, 2011 at 23:11
  • You can erase cache from fastboot as well.
    – Broam
    Aug 1, 2011 at 18:11
  • 1
    Not much of an answer if all of the salient information is at another site. When that link stops working this answer will be useless.
    – ale
    Sep 17, 2012 at 19:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .