0

e739 I had used the twrp recovery.img from e730 and it worked fine, flashed cm7, worked great. Then i saw that someone had made twrp for e739. I was going to flash that as well as an unofficial cm10 rom. I wiped system, then i thought i should probs do the recovery first, so i did, rebooted into recovery, and now, along with 4 tiny screens and pink everything, I can't flash anything. It would seem the recovery doesn't work. How can I fix this?

EDIT: I am getting an error saying it can't open the zip file. The file is fine, i did MD5 check

0

If you can access an adb shell, you can flash a recovery.

If you open the recovery zip up and go to META-INF/com/google/android/ you will find 2 files, you want "updater-script". Open this up with a text editor, and look for something that says dd followed by recovery.img. In that line near the end there should be something like "of=/dev/block/mtdblocknumbersnstuff"

copy that line. From here on I will refer to that as "of=x"

now go back to the zip folder and extract recovery.img to somewhere convienient. Connect your phone to the computer and boot into recovery, then run

adb push /path/to/recovery.img /data/recovery.img
adb shell
#cd data
#ls

Here it can output a bunch of stuff or nothing, but you are looking for "recovery.img" If you see it, good job, continue. If not, start over from the "adb push" command.

dd if=recovery.img of=x

From there reboot back into recovery and you should see the recovery you just flashed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.