2
Device: Nexus 7 (2013 WIFI)
ROM: AOKP_FLO_KITKAT_NIGHTLY_2014-07-31
Rooted: Yes
Recovery: TWRP (Not sure if this is needed)

I am posting this because I recently started getting "insufficient storage" error on my device. I've had this before and I knew exactly had to fix it because I had come back from a vacation then and there were a lot of pictures on the device; So it was a simple matter of moving all the pictures and videos off the device for it to start working again.

This time however it is a little confusing for me. I will start with some pictures:

Settings > Storage ES File Explorer
Settings > Storage / ES File Explorer > Top_left menu > Tools drop-down > SD Card Analyst (click images for larger variants)

So far everything looks fine, I seem to have a lot of space left to install one measly app right? Just to confirm, I used Clean Master to try to move some apps to device storage:

Clean Master
Clean Master > App Manager > Move

No gimmicks here, Clean Master sees that I only have one storage medium on my device. So why do I get these errors?

Google play AIDE
Google play (Trying to install an app that is less than 1MB in size) / AIDE (Trying to run an app)

I'm just confused about the whole thing. Everything else seems to be saying I have enough space, but apps are not being installed because I don't have enough. What can I do here?

EDIT: Even more weirdness, it won't let me install the 300Kb file with the image I posted above, but it lets me install a 3Mb file from the playstore. Basically I can install some apps but not others and it doesn't matter the size, my device just wants to make me crazy no problem. Ex. This app (2.6M) installed fine, but this one (2.1M) didn't due to "Not enough space".

What I have tried:

DiskUsage

Couple observations:

--> It let me install this App and still not letting me install the other apps I have tried with the insufficient memory message still showing

--> The above pic shows that I have enough space left on the /data partition to install atleast A LOT of apps!

  • Output of running the df command:

Terminal Emulator

Note I have tried the solution posted at the "Possible Duplicate" link and it did not work nor did I expect it to. The problem here is not that I have insufficient space to install apps because as you can see, I have a lot of space and I am able to install some apps. The problem is deeper than that and probably has to do with the way files are installed on my tablet

  • possible duplicate of Google Play: Error downloading app - insufficient space – Dan Hulme Aug 30 '14 at 7:53
  • Hint: A good starter on this topic is our insufficient-memory tag-wiki. Contains first aid, and links to several of the most important posts here for that issue. – Izzy Aug 30 '14 at 12:56
  • Thanks for the comments, I have tried the solutions there, but either some solutions are not applicable to my situtation (i.e. My tablet uses solely internal storage and I have over 8gb of internal storage left and I can still install some apps but not others) or they are not for my device (Most of the solutions are for devices other than Nexus 7 or related to android market which has long been replaced by play store) – smac89 Aug 30 '14 at 14:55
  • So the problem seems to have resolved itself. After restarting for the umpteenth time, it is finally working now. My God! – smac89 Aug 30 '14 at 22:09
  • Have you tried factory resetting? Keep a backup beforehand. – Minh Duc Vo Jul 9 '18 at 17:21
0

You might have needed to wipe the user cache, which I think happens automatically over time (hence the umpteen reboots solving the problem).

0

try to flash EBR to increase your system memory from phone memory. you can find about this in detail if you search with your phone model.

Warning ! this process might cause your phone DEAD! void warranty and boot-loops

this process is done with specific ROM flasher of that phone brand.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.