I have been using Samsung Galaxy s4 stock firmware up until now. Yesterday I switched to AOKP 4.4.4 (18/10/2014 build) and I've noticed that none of my old ringtones work (12 unrelated ringtones). I tried converting some of them to ogg, mp3 and wav formats with audacity. Whatever i do, they do not appear in ringtone list when moved to system/media/audio/ringtones. They cannot be selected with ES explorer - I get "Wrong file type, please select again" message. If I select them with root explorer the ringtone is set to "None".

Some mp3 files in my music library work, but not the ringtones.

I assume it has something to do with ringtone format, however, I have got no idea where to start looking.

Is there any setting I could change or an app I could change / install to add the compatibility? Is there any particular app responsible for sound playback in android?

EDIT: I am running AOKP on Samsung Galaxy S4.

EDIT2: I recently installed latest official firmware. During instalation I tried resetting to phone default firmware and ringtones worked. Now that I am on new official firmware, old ringtones do not work again. Also, On the new FW I used official ringtone selection tool (that creates a ringtone file). The ringtone created works in ringtone selector list, but cannot be added to list if removed from the list or if moved.

This leads me to believe problem is with some update all newer firmwares (including AOKP) have.

No real answer to this question, I am forced to use a 3rd party app to use my old ringtones.

  • Possible duplicate of "Wrong file type, please select again" when choosing a ringtone – Sparhawk Jun 14 '17 at 23:49
  • The other question is newer, but has more views, more votes, more answers, better answers (i.e. one that worked for me), and is linked first on Google (for me). – Sparhawk Jun 14 '17 at 23:50
  • @Sparhawk That's good logic, but this question has an accepted answer, while the other has a collection of suggestions for lots of different phones, and it seems like the .nomedia suggestion solved the problem in this case but doesn't work for the other question. If the answers are different, they can't be duplicates. – Dan Hulme Jun 15 '17 at 8:47
  • @DanHulme Fair enough, and thanks for the reply. I'm usually at Unix/Linux, and I get the feeling that they're a bit more liberal with closing for dupes; presumably each SE site is a bit different. – Sparhawk Jun 15 '17 at 10:40
  • It's always a judgement call, and in this case the fact that both questions have several good answers swung it for me. – Dan Hulme Jun 15 '17 at 10:43

In my OnePlus 2 running OxygenOS 2.2 (Android 5.1.1) the problem was solved by removing .nomedia in the root of the SD card, copying the audio folder from the media folder to the root of the SD, and then moving it back to the media folder. Don't ask me why but it worked again.

  • Uh.....I can't believe something like that worked, but it did. – Zero Jan 29 '16 at 20:34

It's weird that your ringtones are still incompatible after conversion to the Ogg Vorbis format, because it (as you probably already know) is what Android's native ringtones come in.

Since you mentioned that you put your files in /system/media/audio/ringtones, it is worth a try to check and set the permissions of your files. It's as easy as

chmod 0644 /system/media/audio/ringtones/*

in a terminal emulator or through ADB.

If you want, you can also put your ringtone files in /sdcard/media/ringtones and do a reboot. You should be able to see, preview, and set your ringtones in Settings. (This works with regular MP3 files, as I've tested months before.)

P.S. Since you also said you've tried using Audacity, it's worth noting that Android doesn't repeat custom ringtones when they stop playing (as is the expected behaviour with call ringtones) unless you include a tag named ANDROID_LOOP set to true in the ringtone's metadata.

  • No it's not permissions, originally, I saved the ringtones to SD card and made sure that permissions are set after it failed the first time. – Zero Oct 27 '14 at 5:36

I dont know why it works, but re-namimg a file from *.mp3 to *.wav makes the file work as a ringtone.

If you then rename it back to *.mp3, it still works.

No idea why.

  • Renaming .mp3 to .wav worked for me! Thanks for advice – Aleks Shindje Feb 22 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.