0

I have a newer phone (an LG G2), and I'm trying to develop on it using a new laptop for the first time (I've done this before w/ other phones and other computers).

I've installed all of the Android SDK and Java SDK components on the laptop. On my phone, I've enabled Developer Options, and I've checked the "USB debugging" checkbox.

However, when I connect my phone to the laptop, I only get the standard dialog box for charging vs. viewing-files, etc. I don't get prompted to accept an RSA Key... nothing happens.

I've run "adb devices", and the "List of devices attached" is empty. I think I really need to purge my laptop of whatever driver it's using for this phone. Charging and transferring-files works fine, but not debugging. Any ideas?

EDIT: I've also checked Device Manager, and I don't see an "Android" section in my devices. My phone is only listed under "Portable Devices" as "VS980 4G".

Also, When I connect my phone to my computer, I don't see the debugger icon in the notification tray of my phone.

  • 1
    Did you disable MTP? – HasH_BrowN Oct 25 '14 at 5:10
  • How would a disable MTP, @HasH_BrowN? Thanks in advance – WEFX Oct 25 '14 at 15:03
  • 1
    Settings>General>System>PC connection. When I use adb and it doesn't see my device I switch the MTP setting and my PC then sees the device. – HasH_BrowN Oct 25 '14 at 15:59
  • Switch the MTP setting to what? I only have these options: "Charge phone", "Media sync (MTP)", "Internet connection", and "Camera (PTP)". – WEFX Oct 26 '14 at 0:43
2

I ultimately got my phone to enter debugging mode by switching the USB setting to "Internet Connection". Once I did that, I found MORE issues w/ my new Eclipse install, so I just switched to Android Studio and moved on w/ my life.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.