When the device is set to use MTP, neither Windows, nor ADB will detect the device when connect via USB cable. I have tried multiple cables, in multiple USB ports. I have not tried other computers yet, as this is the only one that actually has the driver installed.

Disclaimer: I am running an Unofficial CyanogenMod 12 build of Android 5.0.2

Device : LG G3 (LG-D855)
Android 5.0.2 CM12-Unofficial-20141228
Google USB Driver: Installed
USB debugging: Enabled
PC: Windows 8.1 Pro Update 1
No one, except me, has reported this as an issue in the XDA thread.

I have been unable to get my PC to detect the device via USB since I first installed CM12, which was around 11/10/2014.


adb devices - MTP

If i change to PTP, Windows will detect the device, as will ADB. But Windows will only let me access the internal storage, and Camera folders.


adb devices - PTP

  • Just out of curiosity, did you try PTP mode? I found that adb on my Linux machine would not recognize my wife's G3 unless it was set to PTP mode, goofy as that is. Feb 1, 2015 at 2:28
  • 1
    It did work in PTP, but the problem with that, I wanted to be able to access the files from Explorer and when in PTP you can only get to the Camera files. Feb 1, 2015 at 2:29
  • do you live in the future?? :D - Because you installed CM on 11/10/2015. kinda unlikely isn't it??
    – undo
    Feb 19, 2015 at 10:37
  • 1
    @RahulBasu I am from the future. Wait until you get this version of CM. It is fantastic. - Thanks, for catching that, fixed it. Feb 19, 2015 at 14:08

1 Answer 1


After a couple of days of digging, I found the solution to this issue.

I opened up Device Manager. My first problem is I was looking for Android Composite ADB Interface, which is what it usually is called. I started looking harder. When I noticed ACER Device. My machine is not an ACER, nor do I have any ACER devices attached, or so I thought. I expanded that group and found ACER Composite ADB Interface.

These are the steps that I followed that got my ADB working with my device. YMMV.

ACER Composite ADB Interface

  • Download the latest USB Driver from Google
  • I right clicked this device
  • Uninstall
    • You may need to reboot after. I did.
  • Open device manager up again
    • The device may identify differently, and will probably have a triangle icon.
  • Scan for hardware changes
  • Right click the device again
  • Selected Update Driver Software
  • Clicked on Browse my computer for driver software browse
  • Select the path to the drivers that you downloaded at the first step, check the "Include subfolders" Let me pick
  • Let it install
  • Open a command windows (I had to open as administrator)
  • Run the following:

    adb kill-server

  • Now run:

    adb start-server

  • Finally run:

    adb devices

  • Profit! Success!!
  • This worked! And it was driving me crazy with the Nexus 6. Thanks! :)
    – leenephi
    Jan 5, 2015 at 15:55
  • This worked for me too, but be sure to select the 'delete the old drivers' option when removing the Acer Composite ADB Interface, as it your PC will keep telling you it's an Acer device and won't let you assign new drivers.
    – ED-209
    Mar 17, 2015 at 13:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .