I have a Moto X running Android 5.0.1 and can't install an APK that i've received on my e-mail from a developer on my company.

I already researched a bit about this and none of the similar problems nor solutions worked for me.

What happens in my case is that i downlaod the APK from the e-mail, then go to the Downlaod section and try to install it.

  • I can touch the "Install" button normally (no screen dimming app installed here) and the progress bar of the app being installed appears normally, as if the app was being installed.
  • The option that allows me to install APKs from unknowns sources is also activated (in fact i managed to install other apps on this same smartphone the same way before).

After the progress bar screen i get a message that says "The app wasn't installed" (the original message is in portuguese, this is the most literal translation) and that is it. There is no feedback, no error message, no nothing.

When i try to install the same app but from the Android Studio (running the project on the smartphone) it runs sucessfully, but when i compile it into an APK and send it to be downloaded and installed, it doesn't work.

Any thoughts?

  • Maybe some issues with your mail software/provider? If compiling and installing works locally (from Android Studio) then the app/apk is not the issue. I know from issues with Outlook (every attachment is a winmail.dat) as well as other mail providers.
    – GiantTree
    Commented Feb 5, 2015 at 17:52
  • 1
    This is similar to Google Play Store error code 505 regarding duplicate permission with different keystore on Lollipop, except you didn't get the error code since you installed the APK manually.
    – Andrew T.
    Commented Feb 6, 2015 at 3:26

2 Answers 2


After further exploration I found out what the problem was. It has to do with the permissions declared inside the app.

I plugged my phone into PC for Android Studio and checked the logcat looking for the moment where the error appeared. Here it is:

02-05 15:38:50.828      929-970/? W/PackageManager﹕ Package motoboy.yellowlab.com.br.motoboy attempting to redeclare permission com.startPoint.gmap.MAPS_RECEIVE already owned by br.com.belaapp.profissional

It seems that since both apps want to use the same permission (com.startPoint.gmap.MAPS_RECEIVE) they can't be installed at the same time.

I just performed a test: I uninstalled the belapp.profissional app, then tried to install my APK from Downloads and it worked.

I also found this thread: Issue 1668: Unknown error code during application install: 505. It seems to be an error with Android 5.0 where you can't have two apps which require the same permission, which is absurd.


Download from a website

If you downloaded the APK from a website and merely doesn't open in the File Manager, nor the browser see this issue,

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .