0

I got the CyanogenMod OS installed on my Samsung S3 mini a couple of months ago but since then my Google Play store stopped working, giving the error message: No Connection. Retry. OR Check your connection and try again. I have not been able to update any apps or been able to use any Google+ apps for that matter. Every time I tried opening any app that is related to Google Play, I received a message saying: Unfortunately, (app name) has stopped. I have googled various troubleshooting suggestions but no luck. These include:

  • Clearing the cache of Google Play store, -services and -services framework
  • Checking the date/time on my device
  • Deleting my Google account on my device and re-creating it
  • Deleting the Google Play app from my phone and re-downloading it from www.apkmirror.com

None of the above things worked so I did a factory reset and I tried downloading it again from the above site but still no luck.

One thing I have noticed (not sure whether this might be whats wrong), but if I go to Menu/Settings/My Devices on the Google Play store, then my device model is showing to be 'GT-I8190', but I have a S3 mini. I have tried various ways to either edit or delete and re-creating the device registered but also no luck. I read something about 'root access' but have not really explored the troubleshooting for it, I have no idea what it is but is this something I should look into?

Currently the Play store app is on my phone but I cant use it due to the error message and if I go via the web onto the Google Play website to try and download any app then it just says 'the app will be installed shortly' but nothing happens.

Does anyone know what else I can do? Should I just take the CyanogenMod OS off from my device and if so, how would I go about doing that?

Thank you! Lindi

3

From what you described, to me it seems like you've installed wrong Gapps package (probably for different Android version), check your gapps package, and if it's the wrong one, simply download the correct package and retry with flashing.

In case your Gapps package is correct, you might have flashed it incorrectly. In that case, you might want to reflash both the CM and Gapps files, but wipe the /system partition before flashing. Also, if you've used older Android version before switching to CyanogenMod, you should have wiped the /data partition (that might have also been the problem from what you've described).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.