0

Background

Today and yesterday I tried to upgrade my HTC One X+ from CM 10.2 to CM 11. I knew from before that if I use the build-in updater (Settings-->About phone-->CyanogenMod updates), it successfully restarts and performs the flashing. However after that it gets stuck during booting and the CyanogenMod icon keeps spinning.

From this: https://forums.oneplus.net/threads/guide-cm11s-cm12-nightlies.231709/ I think it's most likely that the problem lays with Gapps. This means I have to manually update CM 11 in the TWRP menu and then Gapps. However flashing either CM 11 or Gapps for CM 11 like this, gives an error that it failed.

This is strange for the following reasons:

  • Flashing CM 10.2 or Gapps for CM 10.2, it succeeds
  • Flashing using build-in CyanogenMod updates, it works with the exact same .zip

I tried first flashing Gapps for CM 11 (it still starts CM 10.2 after this) and then flashing CM 11 both using CyanogenMod updates. However now it hangs a bit at the HTC screen and then automatically goes to TWRP.

Questions

Any inspiration why using Install in TWRP fails? What do I do wrong that I cannot properly update to CM 11?

System

1

You can install it,

First of all try to update to a new TWRP version if possible like you installed it before. Or you might want to go to the bootloader/fastboot on Samsung devices you need to press

Volume up + home + power 

On other devices you must press

Volume up + power

and connect your phone to your PC and install the drivers if not done before, you can install the naked Adb drivers from twrp's site.

This is the link for your device: https://twrp.me/devices/htconexplusinternational.html

You also can connect it to your PC install the drivers and type

adb reboot bootloader

You can find more info on TWRP's site.

put the Gapps/Google apps on the SD card, you might want to use

adb shell push gapps.zip /storage/sdcard0/
Downloads

All after each other.

Or setup mtp for TWRP.

You can do this at the settings mount and enable MTP.

Then push the update zip to your device which is the same as above.

Install the update and wipe the caches.

Then you're all set.

0

As CM 10.2 is a derivate of Android 4.2.2 (JellyBean) and CM 11 is a derivate of Android 4.4.4 (KitKat) the GApps will refuse to work. And making a huge firmware jump like that is always risky. Try the following:

  • Take a Backup, if you still can
  • Wipe your Phone completely (/systen, cache, dalvik)
  • Make a clean CM11 install, restart and flash PA Gapps for CM11
  • Restore your apps
  • The thing is that my TWRP refuses to install CM 11 through the Install option, but CM 10.2 works when using that option. The zip can't be corrupted, because the CyanogenMod updater works, although it doesn't start after that anymore. So if I first clean the phone, I cannot use CyanogenMod updater anymore. – NumesSanguis May 16 '15 at 23:26
  • Then try a Recovery capable of handling kitkat. – TechMod May 18 '15 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.