1

Help needed it's urgent. So I have unlocked bootloader successfully via fastboot. Everything went fine until the end without any error. So I disconnected the device from PC and rebooted it and now it is stuck at boot animation forever. It's the only phone I have now. Any suggestions?

  • Your device should have probably reset the phone after bootloader unlock, but I would still ask, have you tried booting into Recovery mode and doing hard reset (clearing data and all caches)? – Firelord Jun 28 '15 at 16:32
  • That's bizarre because I never heard any device that doesn't have a Recovery Mode! May be I'm living in my own little world. Anyhow, hard reset is like factory reset done by booting into Recovery and doing all the necessary flush. I assume you can still boot into fastboot so try fastboot -w. It will clear userdata and cache. – Firelord Jun 28 '15 at 16:36
  • Hahaha I'm never into stuff like that. So I don't know about these recovery and all. So are you sure about that fastboot -w? What will happen after that? – MANI Jun 28 '15 at 16:43
  • That command will clear userdata (all apps+app data+ Internal SD card stuff) and cache. Alternatively, you can issue fastboot erase userdata and then fastboot erase cache. – Firelord Jun 28 '15 at 16:47
  • Not working I'm getting errors like - not supported, FAILURE etc... – MANI Jun 28 '15 at 16:49
1

I've solved my problem for myself by re-locking the bootloader and then repair the device using Sony PC Companion. Device is again in mint condition ;)
I'll add a supporting link later. Support links-

(1) How to get into recovery mode in Xperia devices?
(2) How to repair software using Sony PC Companion on Windows and using Mac Bridge on OS X?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.