0

This question already has an answer here:

I accidentally deleted Google Play services, Play store and various other apps through Titanium. I tried reinstalling play store through apk (5.7.6) but each time it either gives me many 'Unfortunately Play store has stopped' messages or it works but shows me an error when I try to download an application. I have lost many other google apps such as Maps, Music etc and I need all of these. Tried a factory reset as suggested on some forums but in vain. I'm running CM12: Lollipop 5.0.2 And I'm rooted. Any solutions please?

Thanks in advance.

marked as duplicate by Izzy, bmdixon, Community Jul 11 '15 at 8:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    It's hard to convince that you accidentally ended up deleting all those Google apps, not just a single one. Anyhow, "factory reset" wouldn't work and I don't get why would one even suggest it. It defaults back to factory state, but you just removed the content from the factory (under /system), so how come factory reset would help? You've to flash GAPPS from the custom Recovery, but a CM user would've possibly known it already. Are you by any chance running Cyanogen OS, or using a Yureka device or a OnePlus One? – Firelord Jul 9 '15 at 9:06
  • @Firelord Ummm. No, I flashed CM12, but I'm a newbie at custom ROMs and rooting. :D – shreyasminocha Jul 11 '15 at 12:08
  • Well, that's fine, and at least the issue is solved which matters most. :) – Firelord Jul 11 '15 at 12:24
2

to solve your problem you need to flash the Gapps again follow this steps

  1. Download the minimal Gapps from here this zip is for 5.0.x roms and contain the needed apps (including google play services) and libraries every thing else you can get it from the play store.
  2. reboot to recovery and flash it like you flash any other mod or rom (no wipe needed)
  3. after installation the first boot may take a while since android system needs to update the dalvic cache (now its art and it takes a little longer) so be patient :D .
  4. Now the google apps should work just fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.