2

I have a Samsung S4 Mini (GT-I9195) and successfully installed cm13 with the cm 13 recovery on it. Now I am stuck with the installation of GAPPS by means of TWRP.

I have tried to follow this tutorial to install twrp (3.0.1 or 2.8.7):

a) App Install Method: it tells me that something went wrong and it does not boot the recovery, indeed. What seems wired to me is that when I have to choose an image it shows me the device code serranolteusc and serranoveltexx for my S4 mini rather than serranoltexx, like on the website of cm 13. Is this normal?

(I even tried flashify instead of the twrp manager, but it did not function!)

b) Since I am on linux and have no windows, I cannot use the odin method. But I tried heimdall via heimdall flash --RECOVERY twrp.img --no-reboot to no avail.

c) I tried the dd Install Method via dd if=/sdcard/twrp.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery, but it still does not boot into recovery mode. Is it possible that there is an issue with the path in of=/dev/block/platform/msm_sdcc.1/by-name/recovery?

Is it possible that there is no twrp for serranoltexx available? Can someone help me, please, I want to install the Google Play Store!

  • 1
    I'm far from being familiar with Samsung devices, but speaking about Odin and Linux: Have you tried JOdin3? That's a web-based Odin variant and should work on non-Windows systems. Could be helpful in your case – and finally answer my curiosity on whether it works on Linux (I can't test that without a Samsung device ;) – Izzy Mar 19 '16 at 12:40
  • 2
    I have a serranoltexx device, with TWRP 3.0.0, OP. I grabbed it from this XDA source: forum.xda-developers.com/devdb/project/dl/?id=16834 – Death Mask Salesman Mar 19 '16 at 14:54
  • 1
    After flashing the recovery using dd, what did you immediately do? How did you reboot into recovery mode later? – Firelord Mar 19 '16 at 17:10
  • @ Firelord, I pressed Vol Up, Power, and Home, only to find out that the CM 13 recovery was still installed. – Til Hund Mar 20 '16 at 8:59
  • @ Death Mask Salesman, thank you for the source. How did you end up flashing? With which method did you do it? @ Izzy, would love to try it out myself, but I need java8 for it. I use open-jre, but I will go back to this method if others fail again with the file of Death Mask Salesman. – Til Hund Mar 20 '16 at 9:07
0

It functions now with the file posted by Death Mask Salesman here!

  • Nice to know it worked. As you may have already noticed, you can flash the file via Odin. – Death Mask Salesman Mar 20 '16 at 16:06
  • 1
    Pardon, Heimdall in your case. – Death Mask Salesman Mar 20 '16 at 16:14
  • 2
    The file is not available anymore ... – ucsky Oct 8 '16 at 12:56
0

If you are ever in doubt about partition paths (and said device is supported by CyanogenMod or LineageOS) you can check this from their sources. But to your question at hand, looking at twrp device trees you need to use serranolteusc as serranoveltexx is meant for the newer 64bit variant (why name them the same if beyond me). Using the image for serranolteusc with the heimdall or terminal and dd command should be enough to get TWRP installed.

If that doesn't work, maybe provide a logcat of when you try to dd see if it complains about anything specific.

-1

I rooted my serranoltexx (s4 Mini with LTE) using Kingroot and flashed TWRP using TWRP-App.

  • 3
    No idea what a "serranoltexx" is – but OP asked for an S4 mini. Note that what works on one device doesn't necessarily fit another. If you think your approach should match, please edit your post and include the steps to perform. If not, you might wish to remove it. – Izzy Sep 22 '18 at 18:26
  • Serranoltexx is the codename of the s4 Mini with LTE. – Venji Sep 23 '18 at 15:11
  • 2
    Is that the GT-i9195 OP asks for? Then an edit of your post with some more details (see my previous comment) would be very welcome. – Izzy Sep 23 '18 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.