Note: Some Android texts below are translated to English by me. So if something looks familiar to the text in English Android but do not match exactly, could you please highlight it to me.

I have non-rooted Xiaomi Redmi Note 8 Pro MIUI Global Android 9 PPR1.180610.011 (not mine, I am just helping for my relative). It have started to produce pop-up windows with the following text: "APP_NAME keeps stopping" First error (after each reboot) is from "Google Play Services" (and it cause the almost the biggest number of the errors). Then the same errors are coming from "App Vault" (almost the same amount as "Google Play Services" but I have disabled "App Vault"), "Security", "msa", "Google", "Emoji Keyboard", "Messaging", "Weather", "YouTube"... The details of the error are the same for all errors and are placed below.

My assume that the problem was caused by the cache cleaning performed using MIUI Cleaner.

So I have started searching for the ways to fix this. I have read ma-a-a-any things. I have found several suggestions to fix "Google Play Services" by cleaning cache but I cannot do it using the usual list of apps because it keep closing because of the same error. I have tried adb but adb shell pm clear com.google.android.gms are refusing to work without root access.

Could you please at least suggest an idea how to deal with this. Also the ideas how to disable (at least temporary) such pop-ups are also very welcomed.

Bonus question: I have backed up the Android directory using the file transfer USB mode. Also I have run adb backup -all but not all application was backed up. I have seen some suggestions for rooted devices. But maybe is there any other way to back up every application without root. I know about some all-in-one toolsets that are needed to be installed. However, I prefer enter the commands by myself than some third-party software installation if it is possible.

The details of the error message (I have kept border lines on both pictures): Page1 Page2 Page3 Page4 Page5 Page6 Page7 Page8

(Sorry for the photo quality, I was fighting with the tons of the messages.)

UPDATE 1: Fighting with the errors I have managed to uninstall Google Market updates and clean its cache. Then the app list and app pages stop closing because of the errors. However the pop-up keeps appearing after all cleaning actions with "Google Play Services" :(

1 Answer 1


Well try uninstalling the Google Play Store and Google Play Services's updates. If you can't or it doesn't work, then you can try disabling the Google Play Services (and if it still shows it then the play store itself), and using the Aurora Store instead of the Play Store.

  • Thanks for the idea. Unfortunately, the list of apps and the app page keep closing. So I am not unable to uninstall updates or disable service there. adb disable com.google.android.gms does not work because of SecurityException.
    – Nick Vee
    Commented Jul 17, 2022 at 5:40
  • See Update 1 in the question. I have tried to disable Google Play Service but there is no button "Disable", only "Close" (produced no effect).
    – Nick Vee
    Commented Jul 17, 2022 at 6:25
  • @NickVeld Factory reset?
    – 3060PlayZ
    Commented Jul 19, 2022 at 7:31
  • Before factory reset it is important to backup some application data but I still do not know how :(
    – Nick Vee
    Commented Jul 19, 2022 at 8:12
  • @NickVeld use Google Drive's device backup feature. Look for it or do some research.
    – 3060PlayZ
    Commented Jul 21, 2022 at 10:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .