0

There are already questions about this, but they are quite old and the answers didn't work for me, so I think there should be a separate question for newer Android versions. Also in my case it's intermittent.

Gmail notifications do not arrive most of the time, although very few times they do, for example after a reboot. I have updated the Gmail app, I would also update Google Play Services but it doesn't show up as an app so I guess it's integrated and updates automatically. I have also cleared the Gmail app cache data.

The notification options are all activated for this app (I have checked in the system's notification options and also in the Google options)

Any ideas for something else that I could try?

EDIT:

@Andrew .T's comment seems to be the key. I wasn't able to stop the system from killing my apps, so I installed another email app with Gmail support. Then that app showed the notifications, other times both of them show notifications, and now funnily enough Gmail is showing notifications and the new app is not :/

3
  • 2
    Since Gmail uses push notifications, they usually depend on whether the app is still running in the background or killed. Without knowing which brand/device model, we usually refer the users to Don't kill my app! for self-help. In summary: check the settings for the battery life optimizer.
    – Andrew T.
    Oct 3, 2023 at 7:13
  • 1
    Google Play Services do not show up as app in your app list but you can manually open it's Play Store page by using the following link: play.google.com/store/apps/details?id=com.google.android.gms
    – Robert
    Oct 3, 2023 at 9:10
  • 1
    Google updates its apps at will, mine a couple times last week alone. Is it possible your "intermittent" active notifications occur during the wakened state caused by the updating process? Consider "Play Protect" processes also as an active period; some others.
    – wbogacz
    Oct 3, 2023 at 11:14

1 Answer 1

1

Try running the checklist below - To make sure the settings are correct:

  1. Long press on the Gmail icon to reach its app info page. Allow all notifications from it.

  2. Launch the Gmail app. In the top left, tap Menu. Tap Settings. Select your account. Tap Notifications and select a notification level.

  3. Long press on the Gmail icon. Find Battery > Optimize battery usage > Change the setting to Unrestricted

  4. Turn on: Settings > Accounts > Automatically sync app data (at the bottom of the screen)

Further reading

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .