There are three apps that needs an update on my device, I've got an always-on 3G connection and it's working (I can use whatever app I need), but when trying to download the update from the app store the progress bar reach the end (100% downloaded, should have saved it entirely) but it won't install the new update and the page on the store keeps telling "Downloading..".

I tried clearing the store cache/data several times but didn't work, I tried clearing the app's cache too (the one that needs to be updated) but it wasn't useful.

How can I solve? I didn't do anything to my un-rooted semi-new phone (Galaxy S plus with gingerbread)

  • I noticed that you said you tried clearing the cache & data for the Google Play Store app, and the target app's cache. Can you try to uninstall the application and install it from scratch? That might help. Commented Jul 6, 2012 at 18:56
  • Do you mean the google store or the app that is trying to update? I have three apps: whatsapp, fb messenger and battery saver 2x battery by sam lu (I disabled this too but didn't work) Commented Jul 6, 2012 at 19:04
  • Possible related question: android.stackexchange.com/questions/103066/… Commented Mar 4, 2016 at 12:46

1 Answer 1


I solved this by reinstalling the store update (i.e. switching it back to the basic market app and let it update again)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .