I've had my Galaxy S3 for a few months now, and have always been able to connect to my PC via USB. A few days ago, it suddenly stopped working. I've found many other Android.SE threads, but none have been able to answer my question.

Symptoms: when I plug the phone in via USB, the phone beeps, I get a lightning bolt on my battery, but that's it. There are no USB options in the pull-down status bar, and the PC does not recognize that a device has been plugged in. Click screenshot for full size.


PC System: Windows 7 x64 with the latest drivers and Kies software from Samsung.

Phone info:

  • Samsung SGH-i747
  • Android version 4.0.4
  • Baseband version I747UCLG1
  • Kernel Version 3.0.8-704434-user
  • Build number IMM76D.I747UCALG1

What I've tried:

  • My wife has an identical Galaxy S3--I plugged her S3 into the same cable, and it was recognized immediately. So I know the PC and cable are both working correctly.
  • Uninstalled and reinstalled the drivers several times anyway -- alone AND with the Kies software.
  • Every USB port on the box
  • Factory data reset--both from the setup menu, and the diagnostic bootup menu
  • USB debugging mode, both on and off.
  • Changing the UART and USB settings in the *#7284# PhoneUtil. After my last factory reset, it's set to PDA/MTP+ADB.

Anything else I should try? Is there a way to determine if the USB plug on the phone is bad?

Edit: screenshot from my wife's phone, using the same computer, same cable:

enter image description here

  • 1
    I have exactly the same problem including connecting my wife's S3. I suspect it is the USB socket in the phone and I am taking back to my provider under warranty for repair. Hope this helps.
    – user27557
    Commented Jan 30, 2013 at 7:11
  • This answer from a very similar (duplicate?) question solved it for me. Power off, remove the battery, wait, then replace. android.stackexchange.com/a/39790/90110
    – Johann
    Commented Oct 19, 2015 at 21:24

6 Answers 6


Update: Try cleanup and reinstall of drivers as mentioned here. Seems to have worked for others.

This seems to be a known issue, and many have had success by using a different cable, connecting to a USB 3 port etc, but clearly, those won't work in your case.

Not sure what your usual usage is, but for file transfers, you can use Airdroid, which connects through wifi.

  • Thanks for the suggestion, but no love from the Galaxy.
    – JoeFish
    Commented Dec 15, 2012 at 16:45
  • Turns out there was one thing I hadn't tried: pull the SIM card out and do a factory reset with format using the *2767*3855# code. I didn't even realize there was a different type of format until just a few minutes ago--somehow I missed it at your link. Since your link is what eventually fixed the problem, I'm accepting your answer.
    – JoeFish
    Commented Dec 15, 2012 at 19:06
  • Thanks. And I'd discovered the factory reset with code recently too - it's called a "hard reset". Had to do it on a friend's Galaxy Ace because her phone had too many messages and no mass-deleting tool would run.
    – Sumesh
    Commented Dec 15, 2012 at 22:54

I had same problem and endlessly researched and did everything except hard reset. Then, when testing the usb cable on another phone, I realized that I wasn't using the usb cable that came with my Galaxy S3 i9300. Once I plugged in the "stock" usb cable, my phone was instantly recognized. Why this is I don't know as the cable I had been using works on all other devices I tested. It even charged my Galaxy S3 i9300. Perhaps, you could be using your wife's usb cable on your phone.

To avoid frustration and countless hours of testing, resetting and reinstalling I would recommend to everyone to first make sure you are using the usb cable that came with your phone instead of a generic one or one from a different model Galaxy S3.

Hope it works for you! Good luck.

  • Wow, the easiest solution worked! Just use the correct USB cable! Thanks. Commented Mar 17, 2016 at 5:34

Also experienced the same problem. In my case, discovered that the cause was from doing a backup in QPST and forgetting to revert the USB settings.

i.e. *#7284# to access PhoneUtil > "Qualcomm USB Settings" > set it to "MTP + ADB"

  1. Download MPT (Media Transfer Protocol) Porting Kit and then install it to your computer. You can download the MPT Porting Kit installation file through the Microsoft’s official website directly.

  2. Reboot your computer.

  3. Reconnect your mobile phone to your computer by using the USB cable.


just faced exactly the same problem with my motorola defy mini.....so was researching what to do....luckily found a solution....when nothing comes in the notification bar and pc doesn't recognize then>>

  1. go to device manager >> my comp>properties>>device manager(left bar)
  2. look for your device (it should be under portable devices and should be marked with yellow exclamatory sign)
  3. uninstall all of them (you may more item there other than your phone)
  4. after that go to usb tether mode from your mobile from settings and turn it on.
  5. then the "turn on usb storage" with a android bot standing screen will appear.
  6. tap to turn on. you have to do it twice. first time turn it on it will automatically turn off. then again tap the button and this should solve the problem. (that moment you will see another notification about tethering in the bar, don't do anything with that).

I'll be happy if the problem is solved..... :)


I had the same problem as everyone else and tried EVERYTHING listed as a resolution. I then did the following and it worked:

  1. Type in code *#7284# which will bring you to the phoneutil screen with PDA, Modem, and QualComm USB Setting options.

  2. Click the Qualcomm USB Driver option and select the MTP + ADB option a little message will appear @ the button of the screen saying saved, now just press the back button all the out to the normal screen.

  3. I then powered off my phone, took out the battery, sim card (tmobile) and micro sd card, put them back in, powered the phone back on and then plugged it in using the usb cable (not original that came with phone) and it started installing the usb drive and then worked. This had been bugging me for 3 months and I finally got it to work. Hope this works for everyone else as this issue was frustrating.

Addon Note (from a user with a VZW Galaxy S3): This worked for me but I had to activate the hidden menu by dialing *#22745927 and changing the hidden menu option to "enable" and then entering the above code. Dial this in the keypad without calling it. It should bring up the menu after entering the last number.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .