1

I have a Samsung Galaxy S 2 (GT-I9100) and baseband version I9100XXMS3. As far as I understand from this page it's a UK modem, which is where I am. When using the latest stock Android I was still able to connect to UK and Swiss mobile networks. After installing CyanogenMod 10.1.3-i9100 (but not flashing the modem as far as I know) while in Switzerland I was able to connect to phone networks, but after coming back to the UK I can no longer get a mobile signal anywhere:

  1. Go to Settings → Wireless & networks → More... → Mobile networks → Network operators.
  2. After some time several network operators are listed. Click "Choose automatically".

At this point, the message "Automatic registration..." displays for about a minute and then it simply says "Can't connect to this network at the moment. Try again later." The mobile signal indicator at the top of the screen stays empty and does not display an "R" for roaming.

In the Android Testing Menu (*#*#4636#*#* → Phone information) "Set preferred network type" setting is set to "WCDMA preferred" (I have no "Network mode" setting on the "Mobile networks" page). I've tried turning radio off and on again.

I have a Toggle Mobile prepaid card with plenty of credit.

  • Have you tried flashing a new modem that works for UK? – geffchang Jan 9 '14 at 6:07
  • This is a UK modem. Why would I need to flash another modem? – l0b0 Jan 9 '14 at 12:49
  • Did you find any solution for this? – thavan Apr 12 '14 at 2:06
  • The modem is a part of the software, not the phone. Usually, CM builds will flash the modem as part of their flash. You've most likely flashed a US modem with the CM install, thus removing the UK modem that was installed before – sloosecannon Sep 8 '14 at 18:37
  • see also: android.stackexchange.com/q/112121/1465 – Matthew Read Nov 25 '15 at 21:31
0

Looks like Toggle Mobile just doesn't work well with my setup. I bought a £2 SIM card from Lycamobile a couple months ago, and it's been working flawlessly with no setup changes. Not much of an answer I'm afraid, but I'd rather lose my remaining Toggle credit than use several more days on this.

-2

I finally got a solution to "no service " after installing cyanogenmod 7 on HTC incredible 2. the ans is simple and est and does not have anything to do with flashing radios, reinstalling rom. simply turn the phone of and remove ye battery to take out yr sim card and switch it bak on without the sim. in it. after it has finished rebooting, make sure the network bars are appearing even without any signal. I e, an x sign on the bars and dat. also airplane mode is off. now go to mobile network settings and choose cdma/GSM (auto) and not the preferred one. now of phone and put bak. sim in and tadaaa, yr. phone will have de most amazing. connection!

  • 2
    It would be great if you could take some time to make this answer readable, formatted and structured. Until then I'm going with a -1. Also, please don't duplicate answers verbatim. – l0b0 Nov 25 '15 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.