3

As of lately i have not being able to update / install SDKs from Android SDK Manager.

I get the following errors:

Preparing to install archives
Downloading Android SDK Platform-tools, revision 20
URL not found: C:\Program Files (x86)\Android\android-studio\sdk\temp\platform-tools_r20-windows.zip (Access is denied)
Downloading Android SDK Build-tools, revision 19.1
URL not found: C:\Program Files (x86)\Android\android-studio\sdk\temp\build-tools_r19.1-windows.zip (Access is denied)
Downloading Google APIs (x86 System Image), Android API 19, revision 5
URL not found: C:\Program Files (x86)\Android\android-studio\sdk\temp\google_apis_x86-19_r05.zip (Access is denied)
Downloading Glass Development Kit Preview, Android API 19, revision 8
URL not found: C:\Program Files (x86)\Android\android-studio\sdk\temp\google-gdk.zip (Access is denied)
Skipping 'Android SDK Tools, revision 23'; it depends on 'Android SDK Platform-tools, revision 20' which was not installed.
Done. Nothing was installed.

I have given full right permissions on the directory that the SDK manager is installed as well as the temp directory

  • This might help, make sure that the temp folder exists in physical form. I had an issue of not able to generate temp folder. – paragb Jun 27 '14 at 5:42
  • temp folder is there. – Suminda Sirinath S. Dharmasena Jun 27 '14 at 6:51
  • 3
    What OS are you running? If it's Windows make sure to Run as Administrator. – RossC Jun 27 '14 at 8:08
  • 1
    To the close-voters: In my opinion this is on topic, since the emulator images are also updated via the SDK Manager, and questions about the emulator are on topic. – onik Jun 27 '14 at 10:33
  • Once I ran as Admin it worked out. But until recently I ran this without doing run as admin. Thanks for the answer. Perhaps if you put it donw as an answer I can accept it. – Suminda Sirinath S. Dharmasena Jun 27 '14 at 15:12
3

While android-studio was already running I tried to run "android.bat" at below location by right clicking and choosing run as administrator which ran SDK manager and download worked for me.

C:\Program Files (x86)\Android\android-studio\sdk\tools\android.bat
  • Running "C:\Program Files (x86)\Android\android-sdk\tools\android.bat" as administrator on Win 10 worked for me. Thanks! – Augusto Barreto Apr 17 '16 at 0:23
  • Just want to say that it is May 2016 now, and this worked for me! I installed Visual Studio and Xamarin, then created a Xamarin.Forms app with no issues. But when I tried to create an Xamarin.Android app in Visual Studio, it asked me to update the SDK. I also installed Android Studio and the latest Java SDK, but my project still asked for a newer SDK and the above was failing. Finally found this thread and ran the .bat file as an admin. Instant success! (Well, I had to close the Windows Explorer since it had a lock on the folder location, and was blocking one of the steps) – Shahed C - MSFT May 12 '16 at 5:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.