When I connect my phone to my laptop via USB, it is able to charge, but I am not able to mount it as a drive. Neither my computer nor my phone recognize that there is a device plugged in. This happened within the past few days, and I don't think that I changed anything on either side.

I already checked the settings and USB debugging is on, USB debugging notify is on, and Stay awake is on in the Development settings menu. I also tried rebooting both devices to see if that would fix it, but it hasn't.

My phone is a Droid Incredible running CM7.0.3. My laptop is running Windows 7.


Try changing usb cable. Bad cables can cause this (at least I had this problem once, which went away simply by using another cable).

  • Unfortunately, I only own the one cable. I'll borrow a friend's cable later and check. I hope it's this simple. – Thomas Owens May 17 '11 at 8:59
  • This turned out to be it. However, I had to try about 3 USB cables before I found out. Annoying... – Thomas Owens May 17 '11 at 15:39

It could also be that Windows 7 or the BIOS disabled that USB port...possibly due to something power related. Have you switched the USB port you're plugged into? Possibly try switching to another USB port.


It's also possible that you've damaged some of the pins on the device's micro USB connector. If connecting it to another computer with another cable doesn't works I could recommend you to contact your dealer for repair :)

  • That's a good call, too. However, I tried multiple combinations of cords and computers. It's definitely my cord either not supporting data or being damaged. – Thomas Owens May 17 '11 at 23:10

As another possibility (although you mention that you did not change anything on the PC): I had a similar problem once when I still had my PALM desktop software (and synchronization software) installed on my PC.

After a log of searching I found out that the PALM sync software used the COMM4 port on my PC.

For some reason, the USB connection between my Galaxy S and my Windows 7 PC used the same port.

Once I uninstalled the PALM software, the USB connection worked flawlessly.

Maybe more technical people at this forum can explain why, but that's what I found out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.