0

I am new to Android but have got a new phone running 5.0.1 using my Gmail account administered by my university in New Zealand. However I am unable to purchase apps in the Google Play store. I am able to download free ones but no any for which I have to pay money. Instead I get an error which says

Error while retrieving information from server[RPC:S-7:AEC-0 ...] The ... is a 13 letter code in the format XXXX-XXXX-XXXXX which seems to change everytime I try.

I have tried restarting, updateing, clearing the cache of the play store, Download Manager, Google play services and have added and removed my primary gmail account and done the same. I have done everything suggested here: https://support.google.com/googleplay/troubleshooter/4592924

How can I fix this?

Thank you.

0

I also posted on the Google play store forum and Byteguy posted suggested that my university was likely blocking purchases. This had not occured to me and sure enough when I set up a new Google account things worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.